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1.0 INTRODUCTION 
The National Weather Service (NWS) is working to improve and expand its hydrologic prediction 
services across the country pursuant to the Advanced Hydrologic Prediction Services (AHPS) program.  
In support of these efforts, Riverside Technology, inc. (RTi) is designing and developing a replacement 
for the current Interactive Calibration Program (ICP).  This effort is focusing on migrating the software 
from C/Motif to Java, maintaining the same functionality, but correcting usability issues.  The software 
will also be more maintainable and facilitate the implementation of new enhancements.  No new 
functionality is planned under the current scope of the project. 

1.1 Document Scope and Purpose 
The purpose of this document is to communicate at a high level the various aspects of the design of the 
replacement ICP.  Refinement of the design will be performed in the appropriate iteration. 

The Design Document describes the system architecture upon which the product will be based.  Strategies 
are identified for logging, troubleshooting, and messaging. 

Components are identified that will be employed by the product as well as interfaces needed to external 
software packages.   

The initial screen shots for the replacement ICP Graphical User Interface are presented. 

1.2 Intended Audiences 
This major portion of this document is directed toward knowledgeable software engineers with some 
understanding of the current ICP product.  The Presentation Layer will be of more interest to potential 
users of the software. 

1.3 References 
Hillel Sukenik, 1.2-UNIX-ICP Interactive Calibration Program (ICP) - Setup Information Hydrologic 

Research Laboratory 

http://www.nws.noaa.gov/oh/hrl/nwsrfs/users_manual/part1/_pdf/12unix_icp.pdf  

Riverside Technology, inc. 2006.  “Concept of Operations and Requirements ICP Redevelopment”, 
Riverside Technology, inc. 

Riverside Technology, inc. 2006.  “ICP User Interface Kickoff Call User Interface Topics”, Riverside 
Technology, inc. 

National Weather Service Office of Hydrologic Development, NWSRFS User Manual Documentation 
http://www.nws.noaa.gov/oh/hrl/nwsrfs/users_manual/htm/xrfsdocpdf.php 
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2.0 THE REPLACEMENT ICP DESIGN 
2.1 Overview 
An overview of the replacement ICP is presented in the following sections.  The goals of the design and 
constraints are discussed, followed by topics that have a system wide scope.  Finally, the Business Layer 
design is presented.  User Interface prototypes are presented in Appendix A. 

2.2 Goals 
The goals of this project are to re-implement ICP to improve usability and maintainability while retaining 
the original functionality. 

OHD classes for data access will be examined for reuse in ICP. 

Open source software is to be employed where feasible. 

2.3 Constraints 
• Retain Functionality  
• Maintainability by OHD 
• Single and Multiple Monitors to be supported 
• Ant      1.6.2 
• ChartDirector   4.1 
• Eclipse    3.2 (Used during development)  
• Java Version   5.0 
• JUnit     3.81 (Used during development) 
• Linux Version   rhel4u2 (2.6x) 
• Hardware    Dual processor 2.4 to 2.8 FHz/2MB CPUs 
• Subclipse     1.0.3 (Used during development) 

2.4 System Architecture 
The high-level system design takes into account the following considerations: 

• Design for an eventual migration in the future to a Services Oriented Architecture (SOA) 
• Observes the Layer architectural pattern (i.e. separation of Presentation layer, Business layer, Data 

access layer). 
• Observes the Partitions pattern (i.e., separation of concerns between domain dependent and domain 

independent components). 
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Services Architecture 
A service is a function that is well-defined, self contained, and does not depend 
on the context or state of other services 
 

Service Consumer Service Provider 

Request

Response
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The following package diagram illustrates the architectural layers adopted for ICP design. 

Although classes in higher levels may be dependent on (have knowledge of) classes in lower levels, the 
opposite relationship is to be avoided. 

 
\Design images\architecture.jpg 

Figure 2-1.  Candidate System Architecture 
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2.4.1 Package Naming Conventions 

OHD has requested that package naming begin with “ohd.hseb.icp” or “ohd.hseb.rfc.icp” and that 
additional levels be kept to a minimum. 

The prefix “ohd.hseb.icp” will be adopted.  Sub-package naming conventions will follow the guidelines 
established by Sun.  See http://java.sun.com/docs/codeconv/html/CodeConventions.doc8.html. 

2.4.2 Error, Warning, Information Strategy 

The strategy for displaying Error/Warning messages is to minimize the interference with the user.  The 
more severe the problem encountered, the more visible the message will be. 

A common terminology must be established in order to discuss the message handling strategy, and is 
presented below. 

2.4.2.1 Terminology 

Error.  Problems encountered during execution that prohibits further execution of the software until 
corrected.  They may be programming errors or user data errors.  

Programming Error.  Result of a divide by zero, array index out of range, or an exception thrown 
without ever being handled. 

User Data Error.  Data undefined or incomplete, data out of range, or data invalid. 

User Correctable Error.  An error that can be eliminated by user intervention. 

Exception.  An abnormal condition that must be handled correctly in order to prevent a program from 
terminating. 

Warning.  Problems that do not prohibit continued execution, but may cause a variance in results. 

Failure.  Failures are a variance from an expected result that is reported to the user.  Not to be confused 
with an error.  (Current functionality does not recognize this classification) 

2.4.2.2 User Notification 

ICP will display the following types of messages as detailed below. 

Message Type User Notification 

Error Displayed in a dialog, which when acknowledged leads to application 
termination. 

Warnings Displayed in the status line. 
Informational Displayed in the status line. 

Format 

 <MessageType> <Message Text> <Suggestions> 

Example 

 Error: FileNotFound.  The file <filename> could not be found. 
 File: <filename> 
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 Path: <path> 
  - Check that the file exists and that permissions exist to access the file. 

Error, Warning, and Informational messages are to contain text describing what went wrong and possible 
actions on the part of the user to rectify the problem. 

The text of the message is to be kept in external files (resource bundles).  This leaves open the possibility 
of internationalization/localization as a future enhancement. 

Any runtime exceptions resulting from programming errors that are thrown by ICP are to be caught, and 
an appropriate message displayed. 

User data validation will only be implemented to the same level as in the current ICP.  It is envisioned 
that additional enhancements could be implemented to detect and warn when incorrect data is entered in 
text fields. 

Error, Warning, and Informational messages will be logged. 

2.4.3 Debugging/Troubleshooting Strategy 

Debugging/Troubleshooting will make use of logging features (see below) to record pertinent 
information. 

• All Error, Warning and Informational messages are to be logged. 
• All exceptions are to be logged. 

In addition logging levels will be optionally used to log: 

• Method enter/exit 
• All Actions 
• Timing 
Normal ICP execution will not include these in the log.  

2.4.4 Logging Strategy 

The java.util.logging package will be used to for ICP logging. 

The logging file(s) will be located in the directory designated by the apps default token mcp3_icp_iface. 

ToDo: Check whether ICP has write permissions, and that log files persist after the session ends. 

Refer to the java.util.logging javadocs for information on the logging package. 

The log file will contain a header consisting of: 

• ICP version 
• Date/time stamp 
• User 
• Selected environment variables and their values 
• Selected apps_defaults tokens and their values 
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In addition, entries will be made for the following events as they occur: 

• Files accessed 
• Error messages 
• Warning messages 
• Troubleshooting messages 

2.5 Presentation Layer 
See Appendix A for the proposed ICP replacement GUI. 

2.6 Business Layer 
An overview of the business layer may be seen in Figure 2-1.  Candidate System Architecture.  More 
refinement may be seen in Figure 2-2.  Class Diagram of Key ICP Classes, Section 2.7, although the 
business classes are not called out.  The business layer will be refined as appropriate during iterations of 
development. 

2.6.1 Environment 

ICP runs in the NWSRFS software environment.  It uses values specified as apps_defaults tokens and 
environment variables for configuration.  Appendix B provides details abut the MCP3 environment, 
which impacts ICP. 

2.6.1.1 Application Defaults 

See Section B.1.2.  

ToDo: Look at RTi’s NWSRFS_Util.get_apps_defaults(String s) and OHD’s MiscTools.getAppDefaults 
() methods for an implementation. 

2.6.1.2 Environment Variables 

See Section B.1.1 

2.6.1.3 File System 

See Section B.4.3 

2.7 Class Diagram 
The following class diagram provides an overview of class relationships. 
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\Design images\Class Diagram1.png 

Figure 2-2.  Class Diagram of Key ICP Classes 

The class ICP will contain “main” and will initialize the ICP GUI. 

Class ICP will initiate communication with the business/services layer to ascertain apps_defaults tokens 
and environment.  Thereafter GUI interactions will control further processing. 

Additional GUI components (DeckEditor, OperationEditor, etc.) will be lazily initialized upon demand. 

The façade pattern will be used to present a high level interface to the presentation layer embodied by the 
class MCP3Proxy.  MCP3Proxy acts as a substitute (proxy) for MCP3, which is an external process and 
cannot be interacted with at a method level. 

Interfaces (TimeSeriesModel, OperationModel) will be used to abstract time series and operation model 
parameter communications between the business classes & the GUI. 

The Observer/Observable pattern will be used to communicate changes from the business layer upward to 
the presentation layer. 
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The data access classes (BinaryFileReader, FixedFormatIO) isolate system dependent code to the data 
access layer. 

The class diagram presented above should be thought of more as a logical diagram.  Actual class names 
are likely to change.  OHD code reuse is to be taken into consideration. 

2.7.1 OHD Code reuse 

Several OHD classes appear to be of interest for reuse.  The following table summarizes the classes.  

Appropriate code will be utilized by referencing an OHD jar file at run time. 

Table 2-1 Candidate OHD Code for ICP 
Class Description 
ohd.hseb.rfc.util.data.DataPoint  Simple x, y datapoint class.   
ohd.hseb.rfc.util.data.DataTable  A general class that could be used for the data 

model for properties or other data.   
ohd.hseb.rfc.util.data.DataSet  Data model for time series, with an array of Julian 

hour and data values.   
ohd.hseb.rfc.util.data.DatacardData  Class to read/write DataCard time series files 
ohd.hseb.rfc.util.data.ESPData  Class to read the ESP (Ensemble Streamflow 

Prediction) binary file - not directly useful to ICP 
but provides an example of reading binary files 

ohd.hseb.rfc.util.data.FileData  Read/write tables of data.   
ohd.hseb.rfc.util.data.PlotData  Appears to be utility/wrapper code for use with 

ChartDirector. 
ohd.hseb.rfc.util.data.TableModelData  Appears to be an interface to support JTable. 
ohd.hseb.rfc.util.misc.HCalendar HCalendar and some others might have some value 

to process date/times. 
ohd.hseb.rfc.util.misc.SystemSettings  May have some value to persist settings. 
ohd.hseb.rfc.util.misc.MiscTools  Includes getAppsDefaults() method  
ohd.hseb.rfc.util.misc.Messenger  Class for logging/messages, using a design from 

APEX C++ code 
ohd.hseb.rfc.util.misc.HBinaryInputStream  Could be used to read the MCP3 binary files.   

 

2.8 ICP Execution 
ICP will be launched by a shell script “icpnew” during transition to allow using the replacement ICP 
parallel to the existing software.  The script will call JRE (version 1.5.0) to run the main method in ICP. 

The “icpnew” script, jar files, and JRE will be located in standard NWSRFS locations. 
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APPENDIX A: GUI DESIGN 
A.1. Introduction 

This appendix provides a design for the replacement ICP Graphical User Interface (GUI).  

Important GUI elements have been prototyped in Java and screenshots captured for this document.  This 
effort also facilitated evaluation of Java components to be used during development. 

It is important to note that GUIs typically evolve during development as usability issues and user 
feedback are incorporated.  This document captures the initial design; however, it is expected that the 
design will be refined.  

The vocabulary of GUIs may not be familiar to all who read this document; therefore the following 
glossary is provided to facilitate review: 

A.1.1 Glossary 

Checkbox.  A control, consisting of a graphic and associated text, which a user clicks to turn an option on 
or off. 

Dialog.  A secondary window displayed by an application, usually to gather information from users 

Modal dialog.  A dialog that prevents users from interacting with other windows of an application until 
the dialog is closed. 

Non-modal dialog.  A dialog that allows users to interact with other windows of an application without 
being closed. 

Pane or Panel.  An area in a window. 

Radio Button.  One of a group of items, of which only one can be selected at a time. 

Split pane.  A container that enables the user to adjust the relative size of two adjacent panes. 

Window.  A user interface element that contains and organizes the information that users see in an 
application. 

The new ICP design takes into consideration the workflow of a calibration session and mitigating major 
usability issues in the existing ICP software. 

A calibration session consists of: 

1. Start ICP. 

2. Select watershed (MCP3 deck). 

3. Run MCP3. 

4. Examine results. 

5. Edit model (operation) parameters (if results are unsatisfactory) and save to the MCP3 deck. 
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Steps 3 through 5 are repeated until the results are satisfactory.  Calibration requires repeating these steps 
many times. 

During the session, a user will run MCP3 and view results many times.  In order to facilitate this it is 
important that: 

1. Results are easily viewed. 

2. Operation parameters are quickly edited. 

3. MCP3 can easily be run for the currently selected deck. 

These considerations imply that the simulation results of MCP3 runs are by default to be immediately 
displayed and parameters affecting them can be edited with minimal user interaction. 

An evaluation of ICP use indicated that users often review SAC-SMA, SNOW-17, and WY-PLOT 
graphical output (or a combination thereof), and sometimes review PLOT-TS graphical output. 

To accommodate this usage the initial GUI design focuses on a Main Window providing WY-PLOT, 
SAC-SMA, and SNOW-17 graphical output, with related navigation tools to select results display.  The 
PLOT-TS results, which are viewed less often, are displayed in a separate window.   

Non-modal dialogs are employed to facilitate editing Operation parameters.  This allows Operation 
parameter and results windows to remain open, facilitating rapid access. 

Three new features are introduced to improve usability: 

1. The MCP3 control deck, once selected, remains selected. 

2. Option to run MCP3 automatically after Operation parameters are applied. 

3. Option to update results automatically after MCP3 runs. 

The ICP User Interface Kickoff Call User Interface Topics document identified major usability issues in 
the existing ICP in the areas of: 

• Main window organization 
• Control deck selection 
• Updates of MCP3 output displays 
• Operation parameter editing 

These have been taken into consideration in the new GUI design. 

In addition, the GUI design addresses: 

• Observing standards 
o Menus 
o Common controls 
o Dialogs (modal, non-modal) 

• Ease of use 
o Eliminate the need to repeatedly reselect the MCP3 control deck 
o Place oft used functionality to be easily accessible 
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o Avoid “find the window” syndrome (where a window becomes hidden behind other windows and 
the user is forced to search for it) 

Many users use multiple monitors (often 3) to run ICP; therefore, using tabbed panes and other 
mechanisms to conserve screen real estate have not been employed.  It was felt that the primary goal of 
increasing user productivity was more important than screen real estate conservation. 

The major visible changes in the ICP GUI are to reduce the number of windows and increase usability.  
Much of the GUI will appear familiar to those who have used ICP and therefore minimal retraining is 
anticipated. 

The following sections introduce the major GUI elements. 

A.2. Overview of ICP GUI 

The figure below shows some of the more important ICP windows and their relationships. 

1. Select Deck

2. Run 
MCP3

4. Edit SAC-SMA

3. View Graphical and Text 
Results

 
UI_Design_Images\Overview of ICP GUI.png 

Figure A. 1.  Overview of ICP GUI 

A.2.1 Highlights 

Figure A. 1 illustrates the main steps performed during calibration. 

1. Select a control deck from File->Open 

2. Run MCP3 using a tool bar button 
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3. Review results, either in the results area, Time Series Plot, or MCP3 output 

4. Edit operation parameters from Edit-><Operation Name> 

A.2.2 ICP General Button Behavior 

This section describes the general behavior for buttons used throughout the ICP user interface. 

OK: In general, the OK button is used for ICP non-modal dialogs and windows that provide an 
opportunity for the user to make a selection.  When the user clicks OK the dialog is dismissed and the 
user’s selection(s) are applied to the system – either the currently selected deck is selected, or in cases 
where input deck information has been changed, new information is written to the input deck. 

Apply: The Apply button is most often used for ICP non-modal dialogs and windows where the user has 
an opportunity to change input deck information.  When the user clicks Apply the user’s selection(s) will 
be saved to the currently selected input deck and the dialog remains open. 

Cancel: The Cancel button is used for ICP modal and non-modal dialogs when the user has an 
opportunity to make a selection or modify information.  When Cancel is clicked none of the user’s 
selections will be applied to the system and the dialog is dismissed.  In the case of modifying input deck 
information, no changes to the deck will be made. 

Close: The Close button is used for ICP modal and non-modal dialogs generally only for displaying 
information to the user.  When the user clicks Close the dialog is dismissed. 

Undo: The Undo button is used only for the ICP dialogs that display the PE Adjustment, ET-Demand, 
Unit Hydrograph, or AESC curve information.  When the user clicks ‘Undo’ the most recent change to 
the plot/table is canceled and the previous values are restored in the plot/table. 

Undo All: The Undo All button is also used only for the ICP dialogs that display the PE Adjustment, ET-
Demand, Unit Hydrograph, or AESC curve information.  When the user clicks Undo All, all changes 
made to the plot/table since the last OK/Apply are canceled and the original plot/table is restored. 
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A.3. ICP Main Window 

Description: The ICP Main Window is displayed when the ICP program starts.  

Invoked From: ICP is started from the Command line 

When ICP is initially started, the Navigation Area (left, explained below) and Results Area (right, 
explained below) are not populated.  The Title Bar also is not populated. 

The Tool bar buttons for Run MCP3 and Display Time Series are disabled. 

 
\UI_Design_Images\StartUpAnnotated.png 

Figure A. 2.  ICP Main Window when First Visible 

When a deck has been selected (Open Control Deck UI is described in Section A.4) the ICP Main 
Window Title Bar updates to show the name of the selected deck. 

The tool bar button Run MCP3 is then enabled. 
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UI_Design_Images\ControlledDeckSelected.jpg 

Figure A. 3.  ICP Main Window after Control Deck Selected but MCP3 Not Run 

The Navigation Area of ICP Main Window lists the SAC-SMA and SNOW-17 model operations and the 
WY-PLOT operations available for display.  For more information see Section A.6.1. 

Future Enhancement: It is envisioned that if new operations having graphical output were added they 
could also be displayed here. 

The Results area shows the selected Operations output in graphical form in the corresponding labeled 
panes. 

The behavior of the Results Area is described in more detail in Section A.6.2. 
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A.4. Open Control Deck Dialog 

Description: The Open Control Deck Dialog is a modal dialog that displays the 
Region/Basin/Watershed/Deck hierarchy and allows users to select a deck, as well as configure MCP3 
run and display options. 

 
UI_Design_Images\new\SelectDeck-modified.jpg 

Figure A. 4.  Open Deck Dialog 

• Run ICP Automatically 

When checked, MCP3 will automatically be executed with the selected deck when the following 
events are detected in ICP 

1. A new Control Deck is selected 

2. Operation parameters are accepted (Ok) or Applied 

3. The Control Deck is saved in the Control Deck Editor 

Otherwise no MCP3 execution will be performed.  The user must manually execute MCP3, for 
example, by using the Run button on the Tool bar. 

• Display Results automatically 

When checked, results panes that are open will automatically be updated after MCP3 successfully 
runs.  Otherwise, results panes will not be updated and the user must manually affect an update. 

Invoked From:  

• File->Open 
• Tool bar 
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A.4.1 Save As Dialog 

Description: The Save As Dialog displays a list of control decks to save as another name. 

Invoked From: ICP Main Window menu bar File -> Save As…  

 
UI_Design_Images\new\SaveAsDialog.jpg 

Figure A. 5.  Save As Dialog 
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A.4.2 Rename Dialog 

Description: The Rename Dialog displays a list of control decks to re-name. 

Invoked From: ICP Main Window menu bar File -> Rename… 

 
UI_Design_Images\new\RenameDialog.jpg 

Figure A. 6.  Rename Dialog 

A.4.3 Delete Dialog 

Description: The Deleted Dialog displays a list of control decks to delete. 

Invoked From: ICP Main Window menu bar File -> Delete… 

 
UI_Design_Images\new\RenameDialog.jpg 

Figure A. 7.  Delete Dialog 
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A.5. MCP3 Execution Notification Dialog 

Description: The MCP3 Execution Notification Dialog is a modal dialog that displays the results of 
executing MCP3 for a selected control deck.  

There will be little or no change from how this dialog is at present displayed in ICP. 

Invoked From: Tool bar Run MCP3 tool or automatically after other actions. 

 

 
UI_Design_Images\MCP3ExecutionNotificationDialog.jpg 

Figure A. 8.  MCP3 Execution Notification Dialog 
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A.6. Main Window Operations and WY-PLOT Displays 

The Main Window displays SCA-SMA, SNOW-17, and WY-PLOT graphical output. 

 
UI_Design_images\new\WaterYearOnly.jpg 

Figure A. 9.  ICP Main Window – WY-PLOT Displayed in Results Area 
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Figure A. 10 illustrates how SAC-SMA operation results may be displayed. 

The user can quickly change between operations by using the controls in the Navigation area, as well as 
determining which Operational results are currently displayed. 

A single click on the left facing triangle of the Splitter control will maximize the Results area (hiding the 
Navigation area).  It can be restored to its original configuration by a click on the right facing triangle. 

 
UI_Design-Images\new\WaterYearAndSACSMA.jpg 

Figure A. 10.  WY-PLOT Showing SACUPR SAC-SMA Model Operation 
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A.6.1 Navigation Area 

Description: The Navigation Area lists the SAC-SMA, SNOW-17, and WY-PLOT operations that are 
defined in the current deck. 

 
UI_Design_Images\ICPMainFrameNavigationArea.jpg 

Figure A. 11.  ICP Main Window Navigation Area 

The user must click on the radio button next to the name of the SAC-SMA or SNOW-17 operation to see 
view graphical results in the upper part of the Results Area. 

The user must click on the radio button next to the name of the WY-PLOT operation to view a WY-
PLOT operation in the lower half of the Results Area.  The user may only select one radio button from the 
“Operations” group and only one radio button from the “Wateryear” group.  The Navigation Area is a 
vertically scrollable panel so that if the list of operations extends beyond the size of the frame the user 
may still see the whole list. 
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Figure A. 12 shows that the SNOW-17 SNOWUPR operation has been selected in the Navigation area 
and the Results area shows the corresponding results in the Operations pane. 

 

 
UI_Design_Images\new\WaterYearAndSNOW.jpg 

Figure A. 12.  WY-PLOT Displaying SNOW-17 Model SNOWUPR 
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A.6.2 Results Area 

Description: The Results Area is a split pane, with the upper half containing the Operation Results Pane 
and the lower half containing the WY-PLOT Pane. 

Operation Results Pane 

Description: The Operation Results Pane is located in the upper half of the Results Area.  The user’s 
selection from the Operations Group in the Navigation Area is displayed in the Results area.  

Each plot of the selected SAC-SMA or SNOW-17 operation is displayed in an individual pane that can be 
resized vertically. 

 
UI_Design_images\OperationPane.jpg 

Figure A. 13.  Results Area Operation Results Pane 
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WY-PLOT Pane 

Description: The WY-PLOT Pane is located in the lower half of the Results Area and displays the Rain + 
Melt graph and the Discharge Graph in separate panes.  

The user can change the plots displayed in the WY-PLOT Pane by selecting a different radio button from 
the “Wateryear” radio button group in the Navigation Area.  

The Rain + Melt plot pane and the Discharge plot pane can each be vertically resized.  The WY-PLOT 
Pane also utilizes a horizontal scrollbar, and the WY-PLOT Panner, described below. 

 
UI_Design_images\WYPlotPane.jpg 

Figure A. 14.  WY-PLOT Pane 

A.6.3 Results Panner 

Description: The Results Panner is positioned directly below the Results Area.  The Results Panner 
displays an overview of the Results Time Series and controls the selection of the Time range of plots 
displayed in the Results Area.  

 

 
UI_Design_images\WYPanner.jpg 

Figure A. 15.  WY- PLOT Panner 

The Panner provides the ability to horizontally scroll the time axis by positioning the selection rectangle 
(the shaded rectangle shown below) with the left mouse button. 

It also provides the ability to select the range of the Time axis.  This is done by “stretching” the selection 
rectangle by grabbing either end of the selection rectangle and drawing it out.  The cursor will provide 
feedback by changing to represent the user action. 

Future Enhancement: Markers can be displayed on the Panner to indicate points of interest (e.g. periods 
of greatest calibration error) in the WY-PLOT plot.  These points can be clicked on to position the Results 
plots to show the associated time. 
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A.6.4 Edit (Results) WY_PLOT Scale Dialog 

Description: The Edit WY-PLOT Scale Dialog provides controls to allow the user to change the WY-
PLOT X and Y-axis scales. 

The dialog is non-modal, allowing the dialog to remain on the screen until the user chooses to dismiss it.  

Invoked From: 

• ICP Main Window menu bar Edit -> WY-PLOT Scale… 
• Right click on the Panner and select WY-PLOT Scale… 

 
UI_Design_Images\EditWYScale.jpg 

Figure A. 16.  Edit WY-PLOT Scale 
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A.7. Time Series Plot (PLOT-TS) Window 

Description: The Time Series Plot Window displays the PLOT-TS Operations graphical output.  

The Operations available for display are shown in the Navigation Area. 

Selecting a Radio Button causes the selected entry to be displayed in the Results window. 

Future Enhancement: Each plot could be individually selected for display. 

Invoked From: The Time Series Plot Window can be launched from the ICP Main Window menu bar 
View -> Time Series Window. 

 
UI_Design_Images\TimeSeriesAnalysisRTD.jpg 

Figure A. 17.  Time Series Plot Window 
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A.7.1 Navigation Area 

Description: The Time Series Plot Window navigation area displays a list of PLOT-TS Operations for 
the selected deck. 

 
UI_Design_Images\TimeSeriesAnalysisNavigation.jpg 

Figure A. 18.  Time Series Plot Window Navigation Area 

The user may select a PLOT-TS Operation to display in the Time Series Plot Window Results area by 
choosing the radio button next to the PLOT-TS Operation name.  For each PLOT-TS Operation the 
navigation area also displays the plots defined in the PLOT-TS operation, as well as the legend 
information for each times series shown in the plot.  The Time Series Plot Window Navigation area is 
horizontally and vertically scrollable. 
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A.7.2 Results Area 

Description: Time Series Plot Window Results area contains the plots for a PLOT-TS operation.  Each 
plot can be vertically resized.  The plots share a common X-axis that can be scrolled left or right.  The X-
axis is identified by the date and Time defined in the PLOT-TS operation. 

 
UI_Design_Images\TimeSeriesAnalysisCenterPane.jpg 

Figure A. 19.  Time Series Plot Window Results Area 
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A.7.3 Results Panner 
Description: The Time Series Plot Window Panner is positioned directly below the Results Area of the 
Time Series Window.  The Time Series Plot Window Panner displays an overview of the selected   
PLOT-TS Operation and controls the selection of the Time range of plots displayed in the Results Area. 

  
 

UI_Design_Images\TimeSeriesAnalysisPanner.jpg 

Figure A. 20.  Time Series Plot Window Panner 

The Panner provides the ability to horizontally scroll the Time axis by positioning the selection rectangle 
(the shaded rectangle) with the left mouse button. 

It also provides the ability to select the range of the Time axis.  This is done by “stretching” the selection 
rectangle by grabbing either end of the selection rectangle and drawing it out.  The cursor will provide 
feed back by changing to represent the user action. 

Future Enhancement: Markers can be displayed on the Panner to indicate points of interest.  These 
points can be clicked on to position the Results plots to show the associated Time. 
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A.7.4 Save Time Series Dialog 

Description: Modal dialog that allows user to select a Time Series to save to disk, for later use. 

The Time Series that are available for saving are displayed a hierarchical order in a scrollable pane.  
Selections for saving are made by clicking in the check box next to the Time Series. 

Invoked From: Time Series Window menu File -> Save… 

 
UI_Design_Images\new\SaveTimeSeries.jpg 

Figure A. 21.  Save Time Series Dialog 

A.7.5 Display Time Series Dialog 

Description: Modal dialog that displays a list of previously saved Time Series that can be displayed on 
the current Time Series Plot. 

Invoked From: Time Series menu File->Open… 

The Open Time Series Dialog is visually very similar to the Save Time Series Dialog 

A.7.6 Time Series Plot Scale Dialog 

Description: The Time Series Plot Scale Dialog provides controls to allow the user to change the scale 
for the X and Y-axes for the Time Series. 

The dialog is non-modal, allowing the dialog to remain open until the user chooses to dismiss it.  

Invoked From: Time Series menu Edit -> Time Series Scale… 
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UI_Design_Images\EditTimeSeriesDialog.jpg 

Figure A. 22.  Time Series Plot Scale Dialog 
 

 
UI_Design_Images\EditTimeSeriesDialog-tab2.jpg 

Figure A. 23.  Time Series Plot Dialog Showing Y-Axis Plot-2 Tab 
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A.8. Wide Listing Dialog 

Description: The Wide Listing Dialog displays the text output of the MCP3 execution. 

The text may be scrolled. 

Future enhancement: Provide a way to position to oft visited sections of the output (e.g. statistics). 

Invoked From: ICP Main Window menu bar View -> Wide Listing 

 
UI_Design_Images\WideOutputListingDialog.jpg 

Figure A. 24.  Wide Listing Dialog 
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A.9. SAC-SMA Parameter Dialog 

Description: The SAC-SMA Parameter Dialog displays the SAC-SMA parameters for editing. 

An editable text field is displayed for each parameter. 

Multi-valued parameters (PE Demand/ET) are edited using a specialized editor reached by clicking on the 
“Curve” button. 

Preserve Ratio/Diff toggles whether ratios or differences are maintained: If there is more than one 
operation, the consistency among the values of a given parameter is maintained.  Some parameters are 
maintained by increment (i.e., if x is added/subtracted from the value in one operation it is added 
to/subtracted from to same value in the other operations).  Other parameters are not adjusted. 

The user may change options for Running ICP and Displaying Results automatically before clicking on 
the Apply or OK buttons. 

The Apply button can be used if the changes are to be saved, but the dialog is to remain open. 

Invoked From: ICP Main Window menu bar Edit -> SAC-SMA Parameters 
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UI_Design_Images\EditSACSMAParameterDialog.jpg 

Figure A. 25.  SAC-SMA Parameters Dialog 

A.9.1 ET-Demand Curve Dialog 

Description: The ET-Demand Curve displays the ET-Demand curve information in a graphical and 
tabular format. 

Curve values can be changed either by editing parameters in the table or by dragging points on the plot. 

Invoked From: The Curve button in the SAC-SMA Parameter Dialog if ET-Demand information is 
present in the deck. 
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UI_Design_Images\ETDemandCurveDialog.jpg 

 Figure A. 26.  ET-Demand Curve Dialog  
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A.9.2 PE-Adjustment Factor Curve Dialog 

Description: The PE-Adjustment Factor Curve displays the PE-Adjustment curve information in a 
graphical and tabular format. 

Curve values can be changed either by editing parameters in the table or by dragging points on the plot. 

Invoked From: The Curve button in the SAC-SMA Parameter Dialog if ET-Demand information is 
present in the deck. 
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UI_Design_Images\PEAdjustmentCurveDialog.jpg 

Figure A. 27.  PE Adjustment Factor Curve Dialog  
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A.10. SNOW-17 Parameters Dialog 

Description: The SNOW-17 Parameter Dialog displays the SNOW-17 parameters for editing. 

An editable text field is displayed for each parameter. 

Multi-valued parameters (AESC) are edited using a specialized editor reached by clicking on the “Curve” 
button. 

Preserve Ratio/Diff toggles whether ratios or differences are maintained: If there is more than one 
operation the consistency among the values of a given parameter is maintained.  Some parameters are 
maintained by increment (i.e., if x is added/subtracted from the value in one operation it is added 
to/subtracted from to same value in the other operations).  Other parameters are not adjusted. 

The user may change options for Running ICP and Displaying Results automatically before clicking on 
the Apply or OK buttons. 

The Apply button can be used if the changes are to be saved, but the dialog is to remain open.  Note that 
the Apply button is missing in the following figure. 

Invoked From: ICP Main Window menu bar Edit -> SNOW-17 Parameters… 

 
UI_Design_Images\EditSNOWParameterDialog.jpg 

Figure A. 28.  SNOW-17 Parameters Dialog 



APPENDIX A: GUI DESIGN 

 40  

A.10.1 AESC Curve Dialog 

Description: The AESC Curve Dialog displays the AESC curve in a graphical and tabular format.  It will 
be similar to the ET-Demand Curve/PE  

Curve values can be changed either by editing parameters in the table or by dragging points on the plot. 

Invoked From: The Curve button in the SNOW-17 Parameter Dialog. 

 
UI_Design_Images\AESCCurveDialog-modified.jpg 

Figure A. 29.  SNOW-17 Parameters Dialog 
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A.11. Unit Hydrograph Dialog 

Description: The Unit Hydrograph Dialog displays the Unit Hydrograph parameters in a table.  For each 
Unit Hydrograph operation defined in the input deck a button will exist for the user to display the unit 
hydrograph curve dialog. 

The user may not edit the values in the table. 

Invoked From: ICP Main Window menu bar Edit  Unit Hydrograph… 

 
UI_Design_Images\UnitHydrographParameters.jpg 

Figure A. 30.  Unit Hydrograph Parameters Dialog 

A.12. Unit Hydrograph Curve Dialog 

Description: The Unit Hydrograph Curve Dialog displays the Unit Hydrograph curve information in a 
graphical and tabular format.  It will be similar to the ET-Demand Curve/PE Adjustment Factor Curve 
Dialog. 

The user can change values by editing parameters in the table or by dragging points in the graph. 

Invoked From: Curve button in the Unit Hydrograph Dialog. 
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UI_Design_Images\UnitHydrographCurveDialog.jpg 

Figure A. 31.  Unit Hydrograph Curve Dialog  
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A.13. Percolation Analysis Dialog 

Description: The Percolation Analysis Dialog displays the Percolation Analysis curves in a graphical and 
tabular format.  It will be similar to the ET-Demand Curve/PE Adjustment Factor Curve Dialog. 

Curve values can be changed either by editing parameters in the table or by dragging points on the plot. 

Invoked From: The ICP Main Window menu bar Edit  Percolation Analysis... 

 
UI_Design_Images\UnitHydrographCurveDialog.jpg 

Figure A. 32.  Percolation Analysis Curve Dialog  
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A.13.1 Curve Dialog 

Description: The Curve Dialog provides fields for adding a new curve to the Percolation Analysis Curve 
Dialog. 

The dialog is populated with percolation analysis curve values in the input deck that the user can modify. 

Invoked From: The Add Curve button in the Percolation Analysis Curve Dialog. 

 
UI_Design_Images\AddCurveDialog.jpg 

Figure A. 33.  Add Curve Dialog 

A.14. Control Deck Dialog 

Description: The Control Deck Dialog displays the current control deck for editing.  This may be 
necessary for Model parameters that ICP does not support. 

Editing operations supported are those of the Swing JTextComponent, similar to Notepad and other 
simple editors. 

ICP will internally ensure that parameter edits are applied to the control deck before the Deck is edited.  If 
necessary the user will be prompted to apply or discard changes prior to editing. 

Invoked from: The ICP Main Window menu bar Edit  Control Deck… 
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UI_Design_Images\EditInputDeckDialog-modified.jpg 

Figure A. 34.  Control Deck Dialog 
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A.15. ICP Functional Requirements and UI Design During Cross Reference Table 

The following table of functional requirements appears in the “Concept of Operations and Requirements 
ICP Redevelopment” Version 4.2 document, Appendix C.  For each requirement, the UI Design 
Document section name and number containing more information about the design for the requirement is 
listed.  The shading in the table groups requirements according to functional areas. 

Table A. 1.  ICP Functional Requirements and Corresponding UI Design Section 

ID Title Description Design Document Section
ICP FR-
1.0C 

Application 
Environment 

The ICP operating environment shall be set 
using the operating system environment or 
configuration files.  This shall include 
directory locations and the path to the MCP3 
executable program. 

No UI design necessary for 
this requirement. 

ICP FR-
2.0C 

Execution Path The ICP execution path shall be set through 
the user’s environment. 

No UI design necessary for 
this requirement. 

ICP FR-
3.0C 

GUI Start The Graphical User Interface shall start 
when the user invokes a command from the 
OS. 

A.3 ICP Main Window 
 

ICP FR-
4.0C 

MCP3 Deck 
Selection 

The ICP shall select an initial MCP3 deck 
through GUI menu and window components. 

A.4 Open Control Deck 
Dialog 

ICP FR-
4.1C 

Directory Creation 
and Deletion 

ICP shall create or delete directories through 
GUI components during deck selection.  The 
application environment shall indicate the 
base directory locations. 

A.4.3 Delete Dialog 

ICP FR-
4.2C 

Copies Chosen Deck 
to Local Directory 

ICP shall work with a copy of the chosen 
MCP3 deck in the user’s defined work 
directory.  The work directory shall be 
defined in the application environment. 

No UI design necessary for 
this requirement. 

ICP FR-
4.3C 

Re-naming Chosen 
MCP3 Deck 

ICP shall be able to re-name the chosen 
MCP3 deck in the work directory.  The user 
through GUI components shall choose the 
new name. 

A.4.1 Save As Dialog 

ICP FR-
5.0C 

Executes MCP3 ICP shall execute MCP3 using the specified 
deck in the work directory.  The user through 
GUI components shall invoke MCP3. 

A.3 ICP Main Window 

ICP FR-
5.1C 

MCP3 Output The ICP shall place MCP3 output in a user 
specified directory. 

No UI design necessary for 
this requirement. 

ICP FR-
5.2C 

MCP3 Notification The ICP shall use GUI components to open a 
notification window of the completion and 
status of   MCP3. 

A.5 MCP3 Execution 
Notification Dialog 

ICP FR-
5.3C 

Viewing MCP3 
Output 

The ICP shall use GUI components to open a 
window for viewing the text MCP3 output.  
These components shall have resizing and 
scrolling capabilities. 

A.8 Wide Listing Dialog 

ICP FR-
6.0C 

Editing the Chosen 
MCP3 Input Deck 

The user shall be able to edit the chosen 
MCP3 input deck by using standard GUI 
components. 

A.14 Control Deck Dialog 
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ID Title Description Design Document Section
ICP FR-
6.1C 

Making and Saving 
SAC-SMA Parameter 
Changes 

The ICP shall use GUI components to edit 
SAC-SMA parameters in the chosen MCP3 
deck.  These parameters include UZK, 
PCTIM, ADIMP, RIVA, ZPERC, REXP, 
LZFPM, LZFSM, LZSK, LZPK, PFREE, 
and SIDE.  The user can preserve the 
ratio/difference for specified parameters in 
any SAC-SMA model in a basin listed in the 
input deck. 

A.9 SAC-SMA Parameter 
Dialog 

ICP FR-
6.1.1C 

Editing ET-Demand 
Curves or PE 
Adjustment Factors 

The ICP shall use GUI or plotting 
components to add or edit the monthly ET-
Demand curve or the monthly PE adjustment 
factors. 

A.9.1 ET-Demand Curve 
Dialog and A.9.2 PE-
Adjustment Curve Dialog 

ICP FR-
6.2C 

Making and Saving 
SNOW-17 Parameter 
Changes 

The ICP shall use GUI components to edit 
SNOW-17 parameters in the chosen MCP3 
deck.  These parameters include SCF, 
MFMAX, MFMIN, NMF, UADJ, SI, 
DAYGM, MBASE, PXTEMP, PLWHC, and 
TIPM.  The user can preserve the 
ratio/difference for selected parameters 
across multiple models in an input file for a 
basin.   

A.10 SNOW-17 Parameter 
Dialog 

ICP FR-
6.2.1C 

Editing AESC Curve The ICP shall use GUI or plotting 
components to edit the nine monthly AESC 
curve values. 

A.10.1 AESC Curve Dialog

ICP FR-
6.3C 

Editing the Unit 
Hydrograph 
Ordinates 

The ICP shall use GUI or plotting 
components to add or edit Unit Hydrograph 
Ordinate values.  The area under the curve 
represented by the UHG ordinates will be 
preserved as any editing is performed. 

A.12 Unit Hydrograph 
Dialog Curve 

ICP FR-
7.0C 

WY-PLOT Operation 
Display 

The ICP shall use standard GUI and plotting 
components for creating the graphical plot of 
the WY-PLOT operation display. 

A.3 ICP Main Window 

ICP FR-
7.1C 

WY-PLOT Operation 
Display Data 

The user shall be able to graphically display 
an instance of each of the SNOW-17, SAC-
SMA, and WY-PLOT operations and have 
the ability to toggle through these multiple 
instances to display any model or operation 
result. 

A.3 ICP Main Window 

ICP FR-
7.1.1C 

WY-PLOT Operation 
Display Vertical 
Resize 

The ICP shall use plotting components to 
allow the user to resize in the vertical 
direction each of the sections of the WY-
PLOT operation display. 

A.3 ICP Main Window 

ICP FR-
7.1.2C 

WY-PLOT Operation 
Display Date-Time 
Axis 

The ICP shall define the X-axis of the WY-
PLOT operation display to be the date-Time 
axis. 

A.3 ICP Main Window 

ICP FR-
7.1.3C 

WY-PLOT Operation 
Display Legend 

The ICP shall use GUI and plotting 
components to display a color-coded legend 
of the WY-PLOT operation display. 

A.3 ICP Main Window 

ICP FR-
7.1.4C 

WY-PLOT Operation 
Display Time Series 
View 

The user shall be able to toggle between 
arithmetic and log scale on the Y-axis. 

A.6.4 WY-PLOT (Results) 
Scale Dialog 
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ID Title Description Design Document Section
ICP FR-
7.1.5C 

WY-PLOT Operation 
Display Data Value 

The ICP shall use GUI and plotting 
components to display a view of chosen 
date-Time and Time series value in the WY-
PLOT operation display.  The user shall be 
able to ‘click’ in the WY-PLOT near the 
Time series to determine the date/hour and 
value of the Time series. 

A.6.2 Results Area 

ICP FR-
7.1.6C 

WY-PLOT Operation 
Display Hydrograph 
Scrolling 

The ICP shall use plotting components to 
allow the user to scroll through the 
hydrograph.  The user shall be able to do this 
either continuously with a scrollbar or by 
selected date-Time intervals. 

A.3 ICP Main Window 

ICP FR-
7.1.7C 

WY-PLOT Operation 
Display SAC-SMA 
Data Axis 

The ICP shall define the Y-axis of the WY-
PLOT operation display to be the data axis in 
units determined by the units of the Time 
series. 

A.3 ICP Main Window 

ICP FR-
7.1.8C 

WY-PLOT Operation 
Display SAC-SMA 
Zone Contents 

The ICP shall plot UZTW and LZTW as 
deficits and UZFW, LZFSW, and LZFPW as 
contents in the WY-PLOT SAC-SMA 
operation display. 

A.3 ICP Main Window 

ICP FR-
7.1.9C 

WY-PLOT Operation 
Display SAC-SMA 
Runoff 

The ICP shall plot the percent of total runoff 
from each of the six runoff components: 
surface, direct, impervious, interflow, 
supplemental base flow, and primary base 
flow.  The ICP shall also show rain plus melt 
and total runoff. 

A.3 ICP Main Window 

ICP FR-
7.1.10C 

WY-PLOT Operation 
Display SNOW-17 
Plots 

The ICP shall plot the following values in 
the WY-PLOT SNOW-17 operation display: 
rain/snow elevation, type of precipitation, 
energy exchange, air temperature, TINDEX, 
snow temperature, liquid water fraction, rain 
plus melt and negative heat storage, rain on 
bare ground, rain plus melt on snow covered 
area, area extent of snow cover, water 
equivalent of snow pack, and observed and 
simulated snow depth. 

A.3 ICP Main Window 

ICP FR-
7.2C 

WY-PLOT Time 
Series Locator 

The ICP shall use plotting components to 
display a small Time series plot of the entire 
WY-PLOT Time series.  This plot shall be 
used to locate and scroll to specific events in 
the Time series. 

A.6.3 Results Panner 

ICP FR-
7.3C 

WY-PLOT Time 
Series Date Range 

The ICP shall use GUI and plotting 
components to allow the user to change the 
range of allowed date values in the X-
direction.  The default values shall be 
obtained from the chosen MCP3 deck. 

A.6.4 WY-PLOT (Results) 
Scale Dialog 

ICP FR-
7.4C 

WY-PLOT Time 
Series Data Range 

The ICP shall use GUI and plotting 
components to allow the user to change the 
range of allowed data values in the Y-
direction.  The default values shall be 
obtained from the chosen MCP3 deck 

A.6.4 WY-PLOT (Results) 
Scale Dialog 
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ID Title Description Design Document Section
ICP FR-
7.5C  

Saving WY-PLOT 
Time Series 

The ICP shall be able to save current SQME 
Time series for use on subsequent WY-
PLOT displays.  The ICP shall use GUI 
components to select a location to save the 
Time series. 

A.3 ICP Main Window 

ICP FR-
7.6C 

Using saved WY-
PLOT Time Series 

The ICP shall use GUI and plotting 
components to display saved SQME Time 
series on the current WY-PLOT.   

A.3 ICP Main Window 

ICP FR-
7.7C 

Modifying the SAC-
SMA Percolation 
Demand Curve 

The ICP shall use GUI and plotting 
components to allow the user to modify the 
percolation demand curve by changing the 
following parameters: ZPERC, REXP, 
LZFSM, and LZFPM. 

A.13 Percolation Analysis 
Dialog 

ICP FR-
8.0C 

PLOT-TS Operation 
Display 

The ICP shall use standard GUI and plotting 
components for creating the graphical plot of 
the PLOT-TS operation that is defined by the 
chosen MCP3 deck. 

A.7 Time Series Plot 
Window 

ICP FR-
8.1C 

PLOT-TS Operation 
Display Data 

The user shall be able to graphically display 
any instance of PLOT-TS information. 

A.7 Time Series Plot 
Window 

ICP FR-
8.1.1C 

PLOT-TS Operation 
Display Vertical 
Resize 

The ICP shall use plotting components to 
allow the user to resize in the vertical 
direction each of the sections of the PLOT-
TS operation display. 

A.7.2 Time Series Plot 
Window Results Area 

ICP FR-
8.1.2C 

PLOT-TS Operation 
Display Date-Time 
Axis 

The ICP shall define the X-axis of the 
PLOT-TS operation display to be the date-
Time axis. 

A.7.2 Time Series Window 
Results Area 

ICP FR-
8.1.3C 

PLOT-TS Operation 
Display Data Axis 

The ICP shall define the units of the Y-axis 
of the PLOT-TS operation display based 
upon the units of the Time series type. 

A.7.2 Time Series Window 
Results Area 

ICP FR-
8.1.4C. 

PLOT-TS Operation 
Display Time Series 
View 

The ICP shall use GUI and plotting 
components to display a view of chosen 
date-Time and Time series value in the 
PLOT-TS operation display.  The user can 
toggle between Log and arithmetic scales in 
any display pane 

A.7.6 Time Series Plot Scale 
Dialog 

ICP FR-
8.1.5C 

PLOT-TS Operation 
Display Hydrograph 
Scrolling 

The ICP shall use plotting components to 
allow the user to scroll through the display.  
The user shall be able to do this either 
continuously with a scrollbar or by selected 
date-Time intervals. 

A.7.2 Time Series Window 
Results Area 

ICP FR-
8.2C 

PLOT-TS Operation 
Display Legend 

The ICP shall use GUI and plotting 
components to display a color-coded legend 
of the PLOT-TS operation display. 

A.7.1 Time Series Window 
Navigation Area 

ICP FR-
8.3C 

PLOT-TS Time 
Series Locator 

The ICP shall use plotting components to 
display a small Time series plot of the entire 
PLOT-TS Time series.  This plot shall be 
used to locate and scroll to specific events in 
the Time series 

A.7.3 Time Series Window 
Panner 

ICP FR-
8.4C 

PLOT-TS Time 
Series Date Range 

The ICP shall use GUI and plotting 
components to allow the user to change the 
range of allowed date values in the X-
direction.  The default values shall be 
obtained from the chosen MCP3 deck. 

A.7.6 Time Series Scale 
Dialog 
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ID Title Description Design Document Section
ICP FR-
8.5C 

PLOT-TS Time 
Series Data Range 

The ICP shall use GUI and plotting 
components to allow the user to change the 
range of allowed data values in the Y-
direction.  The default values shall be 
obtained from the chosen MCP3 deck. 

A.7.6 Time Series Scale 
Dialog 

ICP FR-
8.6C 

Saving PLOT-TS 
Time Series 

The ICP shall be able to save current PLOT-
TS Time series for use on subsequent PLOT-
TS displays.  The ICP shall use GUI 
components to select a location to save the 
Time series. 

A.7 Time Series Window 

ICP FR-
8.7C 

PLOT-TS Time 
Series Display Data 
Value 

The user can ‘click’ in any display pane near 
a plotted Time series to get the 
day/Time/value of the point in the Time 
series. 

A.7 Time Series Window 

ICP FR-
8.8C 

Using saved PLOT-
TS Time Series 

The ICP shall use GUI and plotting 
components to display saved Time series on 
the current PLOT-TS. 

A.7 Time Series Window 
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APPENDIX B: MCP3 NOTES 
This appendix contains notes on MCP3 that will be useful during development. 

The figure below shows the relationship between ICP and MCP3. 

 
Design_Images\RelationshipICPandMCP3.jpg 

Figure B. 1.  Relationship between ICP and MCP3 

B.1. MCP3 Environment 

MCP3 and ICP run in the NWSRFS software environment.  Both use values specified as apps_defaults 
tokens and environment variables for configuration. 

B.1.1 Environment Variables 

Apps_defaults (See Section B.1.2) will be taken from the environment if not in the files. 



APPENDIX B: MCP3 NOTES 

 52  

B.1.2 Apps Defaults 

The following table shows the apps_defaults tokens relevant to ICP, their default value, and description. 

Extracted from I.2-UNIX-ICP-5 

Table B. 1.  ICP Apps_Defaults Tokens 
Token Name Usual Value Description 

mcp_decks $(calb_input)/mcp3/decks ICP - to locate the control decks - this is the 
branch-root for the control deck storage 
structure - requires a subdirectory named 
'regions' 

mcp_dir $(calb_bin) ICP - to locate MCP 
mcp3_icp_iface $(HOME)/icp/mcp3_ntrfc ICP and MCP - directory to exchange data 

and results 
icp_editor vi | nedit ICP name of editor program 

- if not specified an X-Motif Text Widget is 
currently used 

icp_pw hILLEL ICP - minimal protection for control deck tree 
structure maintenance 

calb_data_dir $(calb_input)/mcp3/data MCP - to locate root of search for input time 
series 

home_files_workstation wkOBO ICP - this is the workstation where the user's 
files physically reside - it is used in ICP to run 
MCP on the user's home machine because that 
is where the data interface is located 

icp_interface_workstation present only if different 
from 
home_files_workstation 

ICP - allows placement of interface on 
workstation other than 
home_files_workstation.  - use of this token 
implies maintenance of mcp3_icp_iface token 
- use of $LOGNAME or $USER or what is 
used to identify user is indicated in such 
maintenance (will be removed) 

Note: Use get_apps_defaults <token> to determine the current value in environment. 

B.1.3 Directory Structure 

See MCP3 input and output discussions below. 

B.2. MCP3 Execution 

B.2.1 Scripts 

ICP is located in the directory pointed to by .Apps_defaults token icp_rlse.  It expects the scripts to run 
MCP3 (run_mcp3, run_mcp3_remsh) to be in the same directory. 

Script Description 
run_mcp3 Used to run MCP3 
run_mcp3_remsh Used to run MCP3 
relabel Used to rename control decks 
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B.2.2 Executing MCP from ICP 

MCP3 is launched from icp_menu_clbks.c:mcp_RUN_cb() using the system call: 

system( "rsh <host> cd <>;pwd; ./run_mcp3_remsh 

         <envvar> 
         <df_names.mcp_dir> 
         < in_deck_file> 
         < out_file> 
         <err_file> 
         <df_names.apps_def_tkn>); 

B.3. MCP3 Input 

B.3.1 Control Decks 

The control deck is read into memory in the array cards[] i.e.  card[0] holds the first record, card[n] holds 
the  n-1th record. 

The current implementation of ICP appears to extract operation parameters from the control deck by 
looking for keywords that are known to be located on the first record/ first field of the operation data.  
Then each field is extracted from records by handcrafted code.  There appears to be no method to “parse” 
the data, as there are no field delimiters. 

When Operation parameters are changed, they are written back to the card array, then the card array in 
written out to disk. 

Control decks are stored as branches of a directory structure.  The root of the directory structure is in the 
.Apps_defaults token mcp3_decks.  The layout of the sub-directory structure is fixed: 

$(mcp3_decks) 
 regions 

<region name> 
   <basin name> 
    <watershed> 
     <control deck>.best 
     <control deck>.curr 
     <control deck>.prev 

Control decks follow the FORTRAN input standards.  They are a fixed format, with fields defined by the 
columns they fall in.  Java does not provide by default a package that deals with reading such a format. 

OHD has code to read fixed format files. 

Logical structure of deck: 

<Header> 
DEF-TS 

Time series definitions 

END 
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[<operation> <operationName> 
  operation data (has varying length defined by data)] 

STOP 

<operation> ::= RSNWELEV 
   SNOW-17* 
   SAC_SMA* 
   UNIT-HG* 
   WY-PLOT 

STAT_QME 

 

Any operation can occur multiple times in the control deck. 

<To Do find more info on control deck structure> 

B.3.2 Time Series Files 

It has not yet been verified whether or not ICP accesses Time Series files other than those in the directory 
defined by the apps_defaults token mcp3_icp_iface. 

ICP appears to have enough information to access the observed Wateryear data. 
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B.4. MCP3 Output 

B.4.1 Console Output 

The following output is produced when running ICP/MCP3.  Different values for environment variables, 
apps_defaults, user, & control deck will produce different results. 

in mcp_RUN_cb: mcp  file : 
/awips/hydroapps/lx/rfc/nwsrfs/calb/bin/RELEASE 
                deck file : 
/projects/testicp/calb/input/mcp3/decks/TESTICP/PAYETTE/CONS_
USE/CONS_USE.curr 
                out  file : 
/home/dre/mcp3_ntrfc/CONS_USE.wide_list.curr 
                err  file : /home/dre/mcp3_ntrfc/stop_num.txt 
                sufx file : /home/dre/mcp3_ntrfc/icp_sufx.txt 
             in_deck file : 
/home/dre/mcp3_ntrfc/input_deck.mcp3 
   WAITING... 
 while MCP3 is WORKING...  
/home/dre 
/awips/hydroapps/lx/rfc/nwsrfs/icp/scripts 
/awips/hydroapps/lx/rfc/nwsrfs/calb/bin/RELEASE 
 
 directory for system files:   
/awips/hydroapps/lx/rfc/nwsrfs/sys_files/ 
 directory for oper files:     
/projects/testicp/ofs/files/testicp/fs5files/ 
 directory for reorder files:  
/projects/testicp/ofs/files/ICPO_reor/fs5files/ 
 directory for mod files:      
/projects/testicp/ofs/files/testicp/mods/ 
 directory for grid files:     
/projects/testicp/ofs/files/testicp/griddb/ 
 
 Cleaning up ofs temporary files... 
/home/dre 
 Back From MCP!  HA! 
 MCP3 stopping number (4) <= 4 :: OKAY TO USE RESULTS!!! 

B.4.2 MCP3 Output Files 

A directory specified by the apps_defaults token mcp3_icp_iface is used by MCP3 to pass files back to 
ICP.  The following files may be found in the directory after a MCP3 run.  Exiting ICP normally will 
clear the directory of these files.  Depending on the control deck some files may not be produced and/or 
files not listed may be created. 

No documentation has been discovered to verify the descriptions.  The information will be verified during 
development. 

<controlDeckName> is the name of the watershed. 

 

 

File Name Description 
<controlDeckName>.icp_crd.bin_data.24.curr  
<controlDeckName>.wide_list.curr Output from mcp3.  This should conform to output created by 
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File Name Description 
FORTRAN programs, with a record length of 133 characters, the first 
being a carriage control character. 

icp_crd_out.txt Appears to be a troubleshooting aid, or to simplify MCP3 to ICP data 
transfer. 

icp_sac_out.txt Appears to be a troubleshooting aid or to simplify MCP3 to ICP data 
transfer. 

icp_sno17_out.txt Appears to be a troubleshooting aid or to simplify MCP3 to ICP data 
transfer. 

icp_sufx.txt Appears to be a troubleshooting aid or to simplify MCP3 to ICP data 
transfer. 

icp_wyp_out.txt Appears to be a troubleshooting aid or to simplify MCP3 to ICP data 
transfer. 

input_deck.mcp3 Control deck 
plotts_scr.txt Appears to be a troubleshooting aid or to simplify MCP3 to ICP data 

transfer. 
sac1-ple.sac_sma.bin_data.24.curr WY time series data. 
sac2-ple.sac_sma.bin_data.24.curr WY time series data 
sac3-prp.sac_sma.bin_data.24.curr WY time series data 
sac4-ple.sac_sma.bin_data.24.curr WY time series data 
sac5-prp.sac_sma.bin_data.24.curr WY time series data 
sac6-prp.sac_sma.bin_data.24.curr WY time series data 
sac7-prp.sac_sma.bin_data.24.curr WY time series data 
sac_scr.txt Appears to be a troubleshooting aid or to simplify MCP3 to ICP data 

transfer. 
sn1-plei.snow_17.bin_data.24.curr WY time series data 
sn2-plei.snow_17.bin_data.24.curr WY time series data 
sn3-prpi.snow_17.bin_data.24.curr WY time series data 
sn4-plei.snow_17.bin_data.24.curr WY time series data 
sn5-prpi.snow_17.bin_data.24.curr WY time series data 
sn6-prpi.snow_17.bin_data.24.curr WY time series data 
sn7-prpi.snow_17.bin_data.24.curr WY time series data 
sno17_scr.txt Appears to be a troubleshooting aid or to simplify MCP3 to ICP data 

transfer. 
stop_num.txt Contains the “stop” or completion code for mcp3. 

Platform dependent format.  On Linux it appears to contain at least one 
record, of which the first 3 columns are blank, followed by an integer.  
The record is displayed in the?? window and different messages are 
displayed depending on the value of the completion code. 
0: Completed with out errors being detected 
<=4: Okay to Use results 
>4 Errors detected, but the user should not used the results. 

wy1-plei.wy_plot.bin_data.24.curr WY time series data 
wy2-prpi.wy_plot.bin_data.24.curr WY time series data 
wy3-div8.wy_plot.bin_data.24.curr WY time series data 
wy4-div9.wy_plot.bin_data.24.curr WY time series data 
wy5-div1.wy_plot.bin_data.24.curr WY time series data 
wy6-all.wy_plot.bin_data.24.curr WY time series data 
wy7-all.wy_plot.bin_data.24.curr WY time series data 
wy8-loca.wy_plot.bin_data.24.curr WY time series data 
wyp_scr.txt Appears to be a troubleshooting aid or to simplify MCP3 to ICP data 

transfer. 
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B.4.3 File Formats 

To Do: Formats will be documented here as they are discovered by code examination 

 

 


