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1. Introduction

ICP is an interactive graphical user interface (GUI) that edits parameters for the Manual Calibration
Program (MCP3), runs MCP3, and displays text and graphical results. The existing ICP software
(written in C and using the Motif/X-Windows graphical toolkit) is difficult to maintain and enhance
and is therefore being replaced. The replacement ICP, written in Java, provides the same
functionality as the original ICP, while addressing usability issues. The replacement ICP does not
make any changes to the existing MCP3 program or the file formats used by MCP3.

1.1 Identification
Interactive Calibration Program (ICP) Replacement
Project ID: NID-05-019-SON-05-002

1.2 Document Overview

This testing plan details the work to be accomplished during testing and details the responsibilities of
each participant. Executing the test plan will confirm that the ICP software functionality performs as
expected.

ICP is an interactive program and therefore testers are assumed to have a good working knowledge of
the GUI functionality. Testing GUI applications is challenging because the sequence of user actions
can vary greatly, and GUIs are also impacted by system configuration including window managers,
running remotely, and other “look and feel” issues. Consequently, ICP testing must rely on users
exercising the GUI.

Low-level and automated tests are also important, in order to quickly verify core capabilities and test
system interactions. These tests require some software developer skills and the access to NWS test
computers.

The body of this document summarizes the approach used in testing. Appendix B provides the details
of the test plan, which can be used to verify functionality and be used for final acceptance testing.
This appendix will be updated during development and will be finalized for the final software
delivery. Test results will be provided corresponding to the final test plan.

Testers who receive a stand-alone beta test installer can follow the steps in Appendix B for
operational testing. The plan can be followed as a part of acceptance testing or a subset can be
followed. The ICP User Manual provides additional information about running the software, for free-
form testing. The User Manual may be a more suitable reference for beta testers at RFCs.

2. Testing Approach

The replacement ICP is being developed using an agile approach, with approximately monthly
releases. Interim software releases will be provided to beta testers. Release notes will be provided
giving instructions on the review approach for each release. It is recommended that acceptance
testing not occur for all features in all releases, but wait until near the final delivery. Components that
are indicated to be complete before the final delivery can undergo acceptance testing, whereas
incomplete functionality should be reviewed for usability and overall functionality. For example,
cosmetic features may not be finalized in the first interim release in which the features appear, and
will be finalized in the subsequent release. However, it is likely that changes related to cosmetics and
usability will occur throughout development and therefore full acceptance testing should occur at the
end of the development effort.

1 Version 4.8, ICP Version 1.00.00
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Development and testing are occurring in a configuration for OB8.1, OB8.2 and OB8.3, including
testing on the Ix8 NHDR machine. The software can be migrated to OB8.3 by changing the user’s
account configuration files (e.g., change the DS_BUILD developer environment variable). ICP
development utilizes the MCP3 and NWSRFS software and configuration files supplied with the
standard NWSRFS development (/fs) and operational (/awips) environments. Development tools are
assumed to be consistent with AWIPS OB release 8.3, although newer versions of Java, etc., in later
OB releases should be backward compatible. It is assumed that a version 1.5 Java Runtime
Environment (JRE) is available and will be provided within the installed OB system (see the
sys_java_dir App default token). Because Java 1.5 is available within the OB7.2 AWIPS
configuration, the ICP software developed for OB8.3 can be provided to testers running on OB7.2
systems. If testers do not have an OB7.2 or later system, then arrangements can be made for these
users to login to the NHDR computers.

ICP testing will occur at the following levels:

1. Unit Testing — The ICP replacement is being developed in Java and Eclipse is being used to
manage the developer sandbox. JUnit will be used to unit test low-level code in batch mode.
Unit tests will be run via Eclipse and can also be run from command line Ant targets. Unit
tests will verify the software functionality at a low level and protect against unforeseen
impacts of new development. Primary functionality will be tested, in particular related to
input/output and utility code and the framework will allow additional tests to be added as
additional ICP enhancements are implemented. Unit testing will occur repeatedly as software
developers write code. Software developers will also run unit tests before delivering code to
OHD. OHD developers will be able to check out ICP from the repository and run unit tests.

2. Regression Testing — Note that this type of testing was not originally scoped but some
work was done to investigate regression testing, in order to automate testing. However,
project resources have not been sufficient to fully implement this approach. The
following documentation is provided to allow for possible implementation in future
enhancements to ICP. ICP regression testing will compare the primary output products
from ICP:

a. MCP3 input decks
b. Images from ICP plots

Regression testing will utilize the Abbot software
(http://abbot.sourceforge.net/doc/overview.shtml).  Expected results will be generated by
running the existing ICP, replacement ICP, or through manual edits of MCP3 decks.
Corresponding user interactions will be recorded in the new ICP using the Costello software
and will be replayed in automated fashion using the Abbot software. The resulting output
will be compared with the expected results. This approach can be automated using JUnit
with Abbot. The Abbot software tools can included in the ICP development environment
sandbox as jar files.

The focus of regression testing will be to compare MCP3 input decks (thereby demonstrating
the overall ICP deck editor functionality). Core editing functionality will be scripted to verify
that user actions via the GUI do result in expected file edits.

The test framework for images is somewhat fragile in that images will not exactly match if
windows have been resized, colors have changed, or any of the contents rendered in the
image have changed (e.g., labels, data, sizing of plots, window manager effects). Therefore,
although it is desirable to implement image comparisons, such tests may be difficult to
implement in practice. RTi will attempt to put the framework in place so that additional
development can take advantage of the approach; however, the final result may be more of a

2 Version 4.8, ICP Version 1.00.00
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3.

demonstration, which can be further evaluated and implemented at OHD in later
development.

Regression testing will initially be implemented in the ICP developer sandbox, to allow
developers to verify software during development. Test data, expected results, GUI action
scripts, and controlling test software will also be packaged into an installer that can be
installed in the standard test location (e.g., /awips/hydroapps /testData/icp for OB8.3) and can
be pointed to by scripts that use ICP and system software. Working test scripts will be
provided to run in this configuration. RTi will work with OHD to demonstrate the scripts on
the NHDR Ix8 test machine and work with OHD to modify if necessary based on OHD’s
integration/acceptance testing.

Operational Testing — Operational testing will utilize full data sets and exercise ICP
functionality from a user perspective. Operational testing consists of repeating a list of steps
in order to verify expected behavior and results. A useful and recommended exercise is to
run the existing and replacement ICP in parallel to compare functionality. The core
functionality of the replacement ICP matches the original ICP; however, some enhancements
have been implemented to address usability issues. When running the existing and
replacement ICP in parallel, different actions will be necessary to recreate the same result.
Therefore it is recommended that the replacement ICP is run according to the Appendix B
instructions and that the existing ICP is run in parallel (using whatever actions are required to
achieve the same result — these steps are NOT documented in this test plan because it is
expected that ICP testers are familiar with the existing ICP). Subsequent testing sessions can
skip the comparison of the replacement and existing ICP and focus on running the test cases
for the replacement ICP.

Operational testing will occur by providing selected OHD and RFC users with an ICP beta
installer, which includes the replacement ICP software, test data, and run scripts that
configure the ICP and MCP3 environment. RTi also performs signicant calibration work for
the NWS and calibrators will utilize ICP for production calibration work as soon as features
are available. Operational testing is expected to occur after each software release, at a level
appropriate for the software features in place at the time. Usability and performance
evaluation will occur and feedback will be considered in later releases.

Certification of Requirements from CONOPS

The complete functionality of the existing ICP was documented in the requirements section in the
HOSIP Stage 4 CONOPS document. The requirements and the corresponding test cases are
documented in Appendix B and will be completed as development occurs. In the final release it is
expected that automated tests will be carried out by OHD developers to gain a certain level of
acceptance and the GUI will be tested according to the test plan and free form testing to fully validate
the software.

4.

Roles & Responsibilities

Personnel Roles Responsibilities

Steve Malers RTi Task Manager The task manager will coordinate the
task’s completion.

3 Version 4.8, ICP Version 1.00.00
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5.

Personnel

Roles Responsibilities

Steve Malers

RTi Software Quality
Assurance Manager

Ensure that ICP developer and release
versions conform to the NWSRFS
environment and that development/testing
guidelines are followed.

Michael Kane, RTi Project Engineers Provide test data and serve as initial
Shaun Carney, testers, before release to the NWS.
Michael

Thiemann

Ai Vo Dieu OHD Project Manager Coordinate with RTi Task Manager to

provide information about the NWSRFS
development and test environment.
Coordinate distribution of ICP test
software to the field. Perform acceptance
testing (or identify others to do so).

Mike Smith, Eric
Anderson, RFC
ICP uses

Research Scientists,
Hydrologists

Run ICP as per the test plan and, as
appropriate, perform free form testing,
provide feedback on the new design,
usability, and performance.

Risk Assessment & Management

The principal risks identified for testing are as follows:

# | Risk Management

1 | The development and test | RTi has devoted resources to matching the NWS NHDR machines for
environment for | development and is adhering to the specifications for OB 8.1 release for
developers will not match | operational testing.
that of OHD integrators. Final testing also occurs on the Ix8 NHDR machine.

2 | Insufficient unit tests are | Test-driven development with unit tests is being used for development. In
implemented allowing | particular, data 1/0 code utilizes services that are unit tested before being
runtime errors to manifest. | utilized by other code.

3 | Insufficient regression | Key functionality will be tested with automated regression tests, in particular
tests are implemented, | to compare MCP3 decks as edited with ICP. The framework will also allow

allowing runtime errors to
occur.

extension and additional tests will be added based on the final software.

Errors discovered during development and testing will indicate that
additional regression or unit tests should be implemented. Developers will
coordinate the implementation of such tests.

4 Version 4.8, ICP Version 1.00.00
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# | Risk Management

4 | Insufficient  operational | Major classes of functionality will be defined with test cases.
test cases are de_flned, Errors discovered during development and testing will indicate that
allowing functionality to - . - : .

- . additional regression, unit, or operational tests should be implemented.
go without testing. : . . .
Developers will coordinate the implementation of such tests.
Several ICP users at RTi will be utilized to test ICP in production mode,
while performing calibration work.

5 | The testing process for | Interim software releases, and coordination between RTi and OHD
users will be difficult to | developers will identify impediments to testing and delivery before the final
execute,  resulting  in | delivery, and implement appropriate solutions.
incomplete testing.

6 | Because ICPisa graphical | Use of automated unit and regression tests will over time minimize the need
program, it is difficult and | to rely on human testers.
cost-prohibitive to  keep The ICP replacement design is relatively stable and therefore features will
the test plan up to date and not be undergoing significant change over time
execute all steps of the going sig g '
plan with each release. The new ICP features are more streamlined, facilitating testing and use.

Several ICP users at RTi will be utilized to test ICP in production mode,
while performing calibration work.

7

Feedback from testers is
not received in time to
incorporate in software.

By delivering software in multiple releases, feedback on specific releases
can be planned for and considered in the following release.

5 Version 4.8, ICP Version 1.00.00
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AHPS
AWIPS
GUI
ICP
MCP3
NWS
NWSRFS
OHD
RES-J
RFCs
RTi

APPENDIX A - TABLE OF ACRONYMS

Advanced Hydrologic Prediction Service
Advanced Weather Interactive Processing System
Graphical User Interface

Interactive Calibration Program

Manual Calibration Program

National Weather Service

National Weather Service River Forecast System
Office of Hydrologic Development

Joint Reservoir Regulation operation

River Forecast Centers

Riverside Technology, inc.

6 Version 4.8, ICP Version 1.00.00
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APPENDIX B — TEST PLAN DETAILS

This appendix defines the test plan for each software release iteration. This appendix in particular is
intended to help the NWS with ICP acceptance testing (verifying that ICP provides required
functionality and generates results as intended).

The test plan excludes tests for MCP3 — it is assumed that MCP3 has passed tests defined by its
developers.

B.1. Operational Tests
This section contains information about the operational test cases.

Based on the data requirements determined for ICP testing, the following data sets were selected for
testing and are provided for testing. Additional data sets may be added as development occurs and
special cases are identified.

Table B. 1. Data Sets Used With Operational Testing

KEY
# | INPUT DECK OPERATIONS PERIOD COMMENTS
1 AFGIX/AFGIX.curr SAC-SMA (2), 1990 - 1999 This deck contains the SAC-SMA
SNOW-17 (2), model with the frozen ground
AFGIX.errl UNIT-HG, component enabled. It will result in an
WY-PLOT (2) additional plot at the top of the WY-
Others are variations. PLOT. This new plot is labeled:
SAC-PLOT, FROST INDEX.
CHANGE-T . L
RSNWELEV Deck AFGIX.errl includes a time list
WEIGH-TS ' that will generate an error — use to detect
MCP3 errors.
2 | AMDK/AMDK.curr SAC-SMA (2), 1990 - 1999 This deck contains a standard set-up of
SNOW-17 (2), the SNOW-17 and SAC-SMA models.
UNIT-HG,
WY-PLOT (2)
3 anr/Antero_ResJ.main RES-J, 1978 - 2005 This data set was used to diagnose a
PLOT-TS problem with setting min/max values for
PLOT-TS and provides another PLOT-
TS example.
4 anrc2/anrc2.best SAC-SMA (2), 1977 - 2004 This data set was used to diagnose a
SNOW-17 (2), problem with the WY-PLOT navigator.
UNIT-HG,
WY-PLOT
5 | API/APL.curr SAC-SMA (2), 1990 - 1999 | This deck was included to exercise the
SNOW-17 (2), API model parameter change option in
UNIT-HG, ICP. However, including an API model
WY-PLOT (2), in the MCP3 deck does not “un-gray-
API-CONT out” the API-CONT option under the
“Edit- Selected Parameters” menu.
6 | combined/simple.resj RES-J, 1981 - 2004 This is a complicated RES-J deck with
PLOT-TS (2) complicated PLOT-TS.
7 Version 4.8, ICP Version 1.00.00
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KEY

# | INPUT DECK OPERATIONS PERIOD COMMENTS
7 MDK/MDK .curr SAC-SMA (2), 1950 - 1999 This deck contains SNOW-17 and SAC-
SNOW-17 (2), SMA models, but it has a SAC-PLOT
UNIT-HG and no WY-PLOT. This was included
to see if the SAC and SNOW states
would still display under the WY-PLOT
menu. They do, there is no hydrograph.

8 mfka/mfka2.curr SAC-SMA (2), 1962 — 2002 | This data set was used to diagnose a

SNOW-17 (2), problem — it had spaces in headers that
PLOT-TS, had to be handled.
WY-PLOT
9 MISSING_DATA/ SAC-SMA (2), 1961 - 1987 This deck has no SNOW-17 operations.
NSNOW.best UNIT-HG (2),
WY-PLOT
10 | PE/AFGIX.curr SAC-SMA (2), 1990 - 1999 This deck has frozen ground in the

SNOW-17 (2), SAC-SMA model and also reads an

UNIT-HG, input time series of PE values. So, the

WY-PLOT (2) PE values in the SAC-SMA model are
not PE-demand but are PE-adjustments.
The old-ICP plot under “Edit-Selected
Parameters-SAC-SMA- ET-demand
Curve” still lists the values as demand —
though they are used in the SAC-SMA
model as adjustments.

11 | SCSM8/SCSM8.curr SAC-SMA (2), 1982 - 2004 The SCSM8.RAIM deck has 1 WY-
SCSM8.RAIM SNOW-17 (2), PLOT with RAIM and 2 WY-PLOT
SCSM8.smll WY-PLOT with no RAIM. The data have a large

range.

12 | SFBM8/SFBM8.curr SAC-SMA (2), 1948 - 2004 Deck with longer period. Also has

UNIT-HG (3) PEAKFLOW time series.
SFBM8/SFBM8.errl
SFBM8.errl will hang MCP3 and ICP -
use for testing extreme conditions.
13 | SOPLAT/sacs2.best SAC-SMA (4), 1975 - 2004 This is an example of a deck with many
SNOW-17 (4), operations.
UNIT-HG (4),
WY-PLOT (3)
14 | speo/speo.curr SAC-SMA, 1955 - 1962 Another test variation that was used to
UNIT-HG, diagnose an initial problem.
WY-PLOT
15 | sptc2/sptc2.curr SAC-SMA (5), 1948 - 2004 Time series names had spaces and it is a
SNOW-17 (5), complicated deck.
UNIT-HG (7),
WY-PLOT (4),
PLOT-TS (1)
16 | TS/TS.curr RES-J, 1995 -1999 | The purpose in including it is to see
PLOT-TS what ICP does when no WY-PLOT is in
the deck.
17 | watc2div/watc2div.best | UNIT-HG (2), 1978 - 2004 Another example that was used for
PLOT-TS (1) initial troubleshooting.
8 Version 4.8, ICP Version 1.00.00
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B.1.1. Operational Test and Results

The following table is a restatement of the functional requirements listed in Appendix D of the ICP
CONOPS 4.4 document and when development is complete test cases will exist for all requirements.
The shading in the table organizes requirements according to functional areas.

Table B. 2. Requirements and Corresponding Operational Tests

1D

Title

Use Case Satisfied

Description

Operational Test
Case(s)

ICP FR-1.0C

Application
Environment

ICP UC-1C

The ICP operating
environment shall be set
using the operating system
environment or
configuration files. This
shall include directory
locations and the path to
the MCP3 executable
program.

1.A - startup

ICP FR-2.0C

Execution Path

ICP UC-1C

The ICP execution path
shall be set through the
user’s environment.

1.A - startup

ICP FR-3.0C

GUI Start

ICP UC-2C

The Graphical User
Interface shall start when
the user invokes a
command from the OS.

1A

ICP FR-4.0C

MCP3 Deck
Selection

ICP UC-3C

The ICP shall select an
initial MCP3 deck through
GUI menu and window
components.

2.C

ICP FR-4.1C

Directory Creation
and Deletion

ICP UC-4C/ ICP
UC-5C/ ICP UC-
6C/ ICP UC-12C

ICP shall create or delete
directories through GUI
components during deck
selection. The application
environment shall indicate
the base directory
locations.

Omitted based on
kickoff and user
feedback. See 7A-
7B for save/copy
features.

ICP FR-4.2C

Copies Chosen
Deck to Local
Directory

ICP UC-13C

ICP shall work with a copy
of the chosen MCP3 deck
in the user’s defined work
directory. The work
directory shall be defined
in the application
environment.

2.A — startup
7TA-T7D

ICP FR-4.3C

Re-naming
Chosen MCP3
Deck

ICP UC-7C

ICP shall be able to re-
name the chosen MCP3
deck in the work directory.
The user through GUI
components shall choose
the new name.

7TA-7B

Version 4.8, ICP Version 1.00.00
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1D

Title

Use Case Satisfied

Description

Operational Test
Case(s)

ICP FR-5.0C

Executes MCP3

ICP UC-8C

ICP shall execute MCP3
using the specified deck in
the work directory. The
user through GUI
components shall invoke
MCP3.

2N-2R

ICP FR-5.1C

MCP3 Output

ICP UC-13C

The ICP shall place MCP3
output in a user specified
directory.

S5A-5D

ICP FR-5.2C

MCP3
Notification

ICP UC-9C

The ICP shall use GUI
components to open a
notification window of the
completion and status of
MCP3.

2Q - 2R

ICP FR-5.3C

Viewing MCP3
Output

ICP UC-11C

The ICP shall use GUI
components to open a
window for viewing the
text MCP3 output. These
components shall have
resizing and scrolling
capabilities.

5.A-5D

ICP FR-6.0C

Editing the
Chosen MCP3
Input Deck

ICP UC-10C

The user shall be able to
edit the chosen MCP3
input deck by using
standard GUI components.

3.A-3H

ICP FR-6.1C

Making and
Saving SAC-SMA
Parameter
Changes

ICP UC-14C

The ICP shall use GUI
components to edit SAC-
SMA parameters in the
chosen MCP3 deck. These
parameters include UZK,
PCTIM, ADIMP, RIVA,
ZPERC, REXP, LZFPM,
LZFSM, LZSK, LZPK,
PFREE, and SIDE. The
user can preserve the
ratio/difference for
specified parameters in any
SAC model in a basin
listed in the input deck.

AA - 4C, 4F

ICP FR-
6.1.1C

Editing ET-
Demand Curves
or PE Adjustment
Factors

ICP UC-15C

The ICP shall use GUI or
plotting components to add
or edit the monthly ET-
Demand curve or the
monthly PE adjustment
factors.

4D - 4E

10
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1D

Title

Use Case Satisfied

Description

Operational Test
Case(s)

ICP FR-6.2C

Making and
Saving SNOW-17
Parameter
Changes

ICP UC-16C

The ICP shall use GUI
components to edit
SNOW-17 parameters in
the chosen MCP3 deck.
These parameters include
SCF, MFMAX, MFMIN,
NMF, UADJ, SI,
DAYGM, MBASE,
PXTEMP, PLWHC, and
TIPM. The user can
preserve the
ratio/difference for
selected parameters across
multiple models in an input
file for a basin.

10.A-10.D

ICP FR-
6.2.1C

Editing AESC
Curve

ICP UC-17C

The ICP shall use GUI or
plotting components to edit
the nine monthly AESC
curve values.

11.A-11C

ICP FR-6.3C

Editing the Unit
Hydrograph
Ordinates

ICP UC-18C

The ICP shall use GUI or
plotting components to add
or edit Unit Hydrograph
Ordinate values. The area
under the curve
represented by the UHG
ordinates will be preserved
as any editing is
performed.

12.A-12]

ICP FR-7.0C

WY-PLOT
Operation Display

ICP UC-19C/ICP
uC-20C

The ICP shall use standard
GUI and plotting
components for creating
the graphical plot of the
WY-PLOT operation
display.

6.A-6.E

ICP FR-7.1C

WY-PLOT
Operation Display
Data

ICP UC-24C/ICP
UC-25C/ICP UC-
26C

The user shall be able to
graphically display an
instance of each of the
SNOW-17, SAC-SMA,
and WY-PLOT operations
and have the ability to
toggle through these
multiple instances to
display any model or
operation result.

6.A-6.C

ICP FR-
7.1.1C

WY-PLOT
Operation Display
Vertical Resize

ICP UC-19C/ICP
uC-20C

The ICP shall use plotting
components to allow the
user to resize in the
vertical direction each of
the sections of the WY-
PLOT operation display.

6.A

11
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1D

Title

Use Case Satisfied

Description

Operational Test

Case(s)
ICP FR- WY-PLOT ICP UC-19C/ICP The ICP shall define the 6.A+
7.1.2C Operation Display | UC-20C X-axis of the WY-PLOT
Date-Time Axis operation display to be the
date-time axis.
ICP FR- WY-PLOT ICP UC-19C/ICP The ICP shall use GUl and | 6.A
7.1.3C Operation Display | UC-20C plotting components to
Legend display a color-coded
legend of the WY-PLOT
operation display.
ICP FR- WY-PLOT ICP UC-19C/ICP The user shall be able to 6.E
7.1.4C Operation Display | UC-20C toggle between arithmetic
Time Series View and log scale on the Y-
axis.
ICP FR- WY-PLOT ICP UC-19C/ICP The ICP shall use GUl and | 6.F
7.1.5C Operation Display | UC-20C plotting components to
Data Value display a view of chosen
date-time and time series
value in the WY-PLOT
operation display. The user
shall be able to “click’ in
the WY-PLOT near the
time series to determine
the date/hour and value of
the time series.
ICP FR- WY-PLOT ICP UC-19C/ICP The ICP shall use plotting | 6.D
7.1.6C Operation Display | UC-20C components to allow the
Hydrograph user to scroll through the
Scrolling hydrograph. The user shall
be able to do this either
continuously with a
scrollbar or by selected
date-time intervals.
ICP FR- WY-PLOT ICP UC-19C The ICP shall define the 6.A+
7.1.7C Operation Display Y-axis of the WY-PLOT
SAC-SMA Data operation display to be the
Axis data axis in units
determined by the units of
the time series.
ICP FR- WY-PLOT ICP UC-19C The ICP shall plot UZTW | 6.A
7.1.8C Operation Display and LZTW as deficits and

SAC-SMA Zone
Contents

UZFW, LZFSW, and
LZFPW as contents in the
WY-PLOT SAC-SMA
operation display.
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1D

Title

Use Case Satisfied

Description

Operational Test
Case(s)

ICP FR-
7.1.9C

WY-PLOT
Operation Display
SAC-SMA Runoff

ICP UC-19C

The ICP shall plot the
percent of total runoff from
each of the six runoff
components: surface,
direct, impervious,
interflow, supplemental
base flow, and primary
base flow. The ICP shall
also show rain plus melt
and total runoff.

6.A

ICP FR-
7.1.10C

WY-PLOT
Operation Display
SNOW-17 Plots

ICP UC-20C

The ICP shall plot the
following values in the
WY-PLOT SNOW-17
operation display:
rain/snow elevation, type
of precipitation, energy
exchange, air temperature,
TINDEX, snow
temperature, liquid water
fraction, rain plus melt and
negative heat storage, rain
on bare ground, rain plus
melt on snow covered area,
area extent of snow cover,
water equivalent of snow
pack, and observed and
simulated snow depth.

6.B-6.C

ICP FR-7.2C

WY-PLOT Time
Series Locator

ICP UC-21C

The ICP shall use plotting
components to display a
small time series plot of
the entire WY-PLOT time
series. This plot shall be
used to locate and scroll to
specific events in the time
series.

6.D

ICP FR-7.3C

WY-PLOT Time
Series Date Range

ICP UC-21C

The ICP shall use GUI and
plotting components to
allow the user to change
the range of allowed date
values in the X-direction.
The default values shall be
obtained from the chosen
MCP3 deck.

6.H

ICP FR-7.4C

WY-PLOT Time
Series Data Range

ICP UC-22C

The ICP shall use GUI and
plotting components to
allow the user to change
the range of allowed data
values in the Y-direction.
The default values shall be
obtained from the chosen
MCP3 deck

6.H
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1D

Title

Use Case Satisfied

Description

Operational Test

Case(s)
ICP FR-7.5C | Saving WY-PLOT | ICP UC-23C The ICP shall be able to 7A-7B
Time Series save current SQME time
series for use on
subsequent WY-PLOT
displays. The ICP shall use
GUI components to select
a location to save the time
series.
ICP FR-7.6C | Using saved WY- | ICP UC-27C The ICP shall use GUland | 7.A-7.B
PLOT Time plotting components to
Series display saved SQME time
series on the current WY-
PLOT.
ICP FR-7.7C | Modifying the ICP UC-28C The ICP shall use GUl and | 9.A-9.H
SAC-SMA plotting components to
Percolation allow the user to modify
Demand Curve the percolation demand
curve by changing the
following parameters:
ZPERC, REXP, LZFSM,
and LZFPM.
ICP FR-8.0C | PLOT-TS ICP UC-29C/ ICP | The ICP shall use standard | 8.A-8.D
Operation Display | UC-33C GUI and plotting
components for creating
the graphical plot of the
PLOT-TS operation that is
defined by the chosen
MCP3 deck.
ICP FR-8.1C | PLOT-TS ICP UC-29C The user shall be able to 8.A-8D
Operation Display graphically display any
Data instance of PLOT-TS
information.
ICP FR- PLOT-TS ICP UC-33C The ICP shall use plotting | 8.C
8.1.1C Operation Display components to allow the
Vertical Resize user to resize in the
vertical direction each of
the sections of the PLOT-
TS operation display.
ICP FR- PLOT-TS ICP UC-33C The ICP shall define the 8.C,8.G
8.1.2C Operation Display X-axis of the PLOT-TS
Date-Time Axis operation display to be the
date-time axis.
ICP FR- PLOT-TS ICP UC-33C The ICP shall define the 8.C,8.G
8.1.3C Operation Display units of the Y-axis of the
Data Axis PLOT-TS operation

display based upon the
units of the time series

type.
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1D

Title

Use Case Satisfied

Description

Operational Test

Case(s)
ICP FR- PLOT-TS ICP UC-33C The ICP shall use GUl and | 8.G
8.1.4C. Operation Display plotting components to
Time Series View display a view of chosen
date-time and time series
value in the PLOT-TS
operation display. The user
can toggle between Log
and arithmetic scales in
any display pane
ICP FR- PLOT-TS ICP UC-33C The ICP shall use plotting | 8.E
8.1.5C Operation Display components to allow the
Hydrograph user to scroll through the
Scrolling display. The user shall be
able to do this either
continuously with a
scrollbar or by selected
date-time intervals.
ICP FR-8.2C | PLOT-TS ICP UC-32C The ICP shall use GUl and | 8.C
Operation Display plotting components to
Legend display a color-coded
legend of the PLOT-TS
operation display.
ICP FR-8.3C | PLOT-TS Time ICP UC-30C. The ICP shall use plotting | 8.E

Series Locator

components to display a
small time series plot of
the entire PLOT-TS time
series. This plot shall be
used to locate and scroll to
specific events in the time
series

B.1.2. Operational Test Cases

The test cases listed in the above table above are described in more detail below. The test plan is
divided into sections of high-level components, for example the ICP Main Window. There are
multiple test cases for each component, and each test case includes a set of setup steps and expected
results. The information collected during testing will also be used in preparing the user manual as
software features are finalized.

The following steps assume that ICP has been installed. For example, if using the beta installer, the
software will have been installed under a directory named “icpnew_beta 1.00.00” or similar and the
scripts to run ICP will be located in the test_scripts directory.

The following general comments apply to the test cases:

1. The graphics shown in the following test cases may vary slightly based on window manager
preferences and changes made during development that have not been reflected in an updated
test plan.
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2. Refer to the ICP User Manual documentation for an explanation of the behavior of software
features. It is expected that that person executing the test plan is familiar with basic ICP
features.
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1. ICP Main Window

A. Launch window
a. Change to the test_scripts directory.
b. Launch the ICP software by running the “run_icpnew_testdata” script.
Expected Results:
- The ICP Main Window appears.
- Verify the following in the dialog that appears:
0 The only button enabled on the toolbar should be the Open Deck button.

0 Hover over the Open Deck button on the toolbar — the tooltip should read “Select
a control deck”

- Title bar shows the text “ICP”
- Verify status bar: Shows “Select a control deck”

Eiice I[=] E3
File Edit View Help

=

|

Select a control deck

MainWindow_Startup
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B.

Verify File Menu
a. Select the File menu item
Expected Results:

- Verify that there are menu items enabled under the File menu as shown in the figure
below.

File | Edit View Help

= Open..

& Save As..

Save A Copy...

Save all WY-PLOT Time Series

Save selected WY-PLOT Time Series
Load Saved Time Series...

Clear Displayed Saved Time Series

B Exit

Menu_File
Verify Edit Menu
a. Select the Edit menu item
Expected Results:

- Verify that there are five menu items and that all are disabled: Control Deck, SAC-
SMA..., SNOW-17..., UNIT-HG, WY-PLOT Scale...

Edit | View Help
Control Deck

SAC-5MA..
SMNOW-17..
UNIT-HCG...

WY-PLOT Scale...

Menu_Edit
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D. Verify View Menu

F.

G.

a. Select the View menu item

Expected Results:

- Verify that the following menus are available: “Output Listing...” (disabled), “PLOT-
TS...” (disabled), “Include Graphs in MCP3 Output File”.

View | Help

[T Include Graphs in MCP3 Qutput File

Menu_View
Launch the Help > About dialog
a. Select the menu item Help - About ICP
Expected Results:

- The Help About dialog is displayed (see screenshot below, although version will be for
the current software)

- When OK is clicked, the dialog is dismissed.

Help |

About ICP

Menu_Help

£
'\l,,l ICP release 0.7 ¢6,/20/07

Ok

Menu_HelpAbout
Verify Window Closes using File > Exit
a. Click on menu item File > Exit.
Expected Results:
- ICP main window closes.
Verify Main Closes with X button
a. Change to the test_scripts directory (if not already there).
b. Launch the ICP beta software by running the run_icpnew_testdata script.

c. After the main window appears, click on the X button in the upper right hand corner of
the frame.

Expected Results:
- Verify that the ICP Main Window closes.
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2. Open Deck Dialog
A. Launch Open Deck Dialog
a. Change to the test_scripts directory.
b. Type run_icpnew_testdata at the command line.
c. Open deck by selecting File = Open...
Expected Results:
- Verify Open Deck Dialog appears as shown

A Open
Control decks

o= | TESTICP

[ | Run MCP3 automatically

Cancel
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B. Expand Region
a. Click on the node named TESTICP.

b. Resize the window to see the full selection (the location will vary by user).
Expected Results:

- Region node expands to show children — PETE.

Control decks

T A TESTICP
o _IPETE

[ ] Fun MCP3 automatically

Cancel

Menu_File_Open_2
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C. Expand Basin

a. Click on the node labeled “PETE” (this is a basin) — either double-click on the word
“PETE” or click on the key symbol to the left of the folder.

Expected Results:
- Basin node expands to show children

Control decks

¢ _MFETE
o= | AFCI
o= | AMDE,
o= | AP
= | MO
o= I MISSING_DAT A
o= _|PE
o= |5C5ME
o= _|5FEME
o= | SOPLAT
o= TS
o= lanr
o= lanrc2
o1 camhbined
o= mfkaz
o= | spen
= | =prc —
O Lt o s

[ I»

[ | Run MCP3 automatically

Ok Cancel

Menu_File_Open_3
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D. Expand Watershed

—Temm

a. Click on the node labeled “AMDK?” (this is a watershed) — double click on the word
“AMDK?” or single click on the key symbol to the left of the folder.

Expected Results:
- Watershed node expands

Control decks

¢ A PFETE o
o= | AFGIK -
o AMDE,

AMODE. curr
o= | AP
o= 1 MOk
o= MISSING _DATA
o= _|PE
o= 15C5ME
o= 15FBME
o= 1 S0PLAT
o= TS
o= lanr
o= lanrc2
o1 camhbined
o= | mfkaz L=
o= | spen
O Lomtr

1]

[ | Run MCP3 automatically

Cancel

Menu_File_Open_4

Placeholder to maintain test numbering
Placeholder to maintain test numbering
Placeholder to maintain test numbering
Placeholder to maintain test numbering

Verify that double-clicking on Region/Basin/Watershed collapses the children below that
node

a. Expand the node Basin node “PETE” (TESTICP/PETE) if it’s not already expanded.

b. Double-click the PETE node (word) or single click symbol to left of folder.

Expected Results:

- Verify that the all children underneath the PETE node collapses.

Verify that double-clicking on Region/Basin/Watershed expands the children below that node
a. Double-click on the PETE node (word) or single click symbol to left of folder.

Expected Results:
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- Verify that the PETE node expands to show its children (same as it was before the node
was collapsed.)

K. Verify Cancel button does not save selection upon cancel
a. Expand the nodes TESTICP/PETE/MDK and select the deck MDK.curr
b. Click the Cancel button
Expected Results:
- Verify that the dialog dismisses
- Verify that no deck has been selected by the following
0 The title bar shows only ICP
0 The status bar still shows the text “Select a control deck”.
L. Verify Deck Selection (Double-clicking on deck)
a. Re-open the Deck Dialog by selecting the Open Deck toolbar button
b. Expand the nodes TESTICP - PETE > AFGIX
c. Select the deck AFGIX.curr
d. Double-click on the deck
Expected Results:
- Verify that the Open Deck dialog is dismissed
- The title bar now shows the name of the selected deck: AFGIX.curr
- The status bar now shows the text “Deck selected: AFGIX.curr”
- MCP3 should automatically run and display WY-PLOT results.

M. Verify Deck Selection (OK Button)
a. Re-open Deck Dialog by clicking on the Open Deck toolbar button
b. Expand the nodes TESTICP - PETE -> API
c. Select the deck APl.curr
d. Click the OK button.
Expected Results:
- The Open Deck Dialog is dismissed.
- The title bar now shows the name of the selected deck: API.curr
- The status bar now shows the text “Deck selected: API.curr”

- Verify that the “Save deck as” (disc symbol), “Refresh” (circular arrows), and “Run
MCP3” (arrow symbol) buttons on the ICP Main Window toolbar are now enabled.

B 1CP: APLcurr

File Edit Yiew Help
a® %

g
K

- MCP3 will automatically run and display the WY-PLOT.
N. Execute MCP and Verify the Run Automatically Checkbox (Double-Clicking)

a. Re-open Deck Dialog by clicking the Open Deck (“Select a control deck) button on the
toolbar

Toolbar
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Check the checkbox “Run MCP Automatically”.

Expand the nodes TESTICP - PETE - AMDK

Select the deck AMDK .curr

Double-click the selected deck.

When the plot appears, deselect the Log Scale in the lower left.

Expected Results:

The Open Deck Dialog disappears
The status bar shows the text “Running MCP....” while MCP is executing.

After MCP has executed the status bar displays the text “MCP Stop Number: 4” to
indicate that the MCP execution was successful.

The title bar also changes to show “ICP: AMDK .curr”

Verify that no exceptions have occurred by looking at the text that is output to the
terminal window.

Operations will be displayed in the left side of the main window.

Initial water year plot data will be displayed at the bottom of the main window with the
legend in the lower left corner
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Erce: aMDK.curr =]

File Edit View Help
=B |2 »

Operations

) None
SNOW-17
) PLBIAB

) PLRIBE
SAC-SMA
) PLBIAB

) PLEIBE
WY-PLOT
® WY-LOC
) WY-TOT

b
3

Rain
Iokelt

e . . .. 0O

MCP3 Stop Mumber: 4

AMDK_AfterRun

O. Verify Run MCP Automatically checkbox is still enabled

a.

Re-open the Deck Dialog by clicking on the Open Deck toolbar button

Expected Results:

Verify that the “Run MCP Automatically” checkbox is still checked.

P. Execute MCP and Verify the Run Automatically Checkbox (OK Button)

a.
b.

Select the deck API.curr (TESTICP - PETE-> APl - APl.curr)
Click the OK button

Expected Results:

The Open Deck Dialog disappears
The status bar displays the text “Running MCP...” while MCP is executing.

After MCP has executed the status bar displays the text “MCP Stop Number: 4” to
indicate that the MCP execution was successful.

The title bar shows “ICP: APIl.curr”
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- The main window is updated to display a new water year plot and list of operations.

- Verify that no exceptions have occurred by looking at the text that is output to the
command prompt.

Q. Execute MCP via the Run button in the toolbar
a. Open the Open Deck Dialog by clicking on the toolbar button
b. Select the deck AFGIX.curr (TESTICP - PETE - AFGIX > AFGIX.curr)
c. Uncheck the “Run MCP Automatically” checkbox (verify)
d. Click OK. A run will automatically occur when the deck is opened.
e

After the Open Deck Dialog is dismissed, on the ICP Main Window toolbar click the Run
button (forward arrow button)

Expected Results:
- While MCP is executing the status bar displays the text “Running MCP...”

- The status bar displays the text “MCP Stop Number: 4” to indicate that the MCP
execution was successful.

R. Execute MCP on a Deck that Returns a non-4 Stop Code
a. Open the Deck Dialog by clicking on the toolbar button
b. Select the deck TESTICP - PETE > AFGIX > AFGIX.errl
c. Check the Run MCP Automatically checkbox.
d. Click OK.
Expected Results:
- The Open Deck Dialog is dismissed
- An Error Dialog appears displaying that the stop number was > 4.
- See screenshot below:

® Error: MCP3 exited with Stop Number = 16

1& il

4]

Main_MCP3_Error
S. Dismiss Stop Number Error Dialog
a. Click OK on the Error dialog
Expected Results:
- The Error Dialog disappears.

27 Version 4.8, ICP Version 1.00.00
9/14/2007



NOAA — National Weather Service/OHD
Interactive Calibration Program — Test Plan and Procedures

- Prior to OK, the status bar shows the text “MCP Stop Number: 16”. It subsequently says
“No WY-PLOT operation defined for this deck.”

T. Close ICP Main Window
a. Click File = Exit on the ICP Main Window menu bar.
Expected Results:
- The ICP Main Window closes.
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3. Control Deck Editor - NOTE: the “icp_editor” environment variable should NOT be set.
If it is set, the user’s editor of choice will be used instead of the build-in editor shown below.

A. Launch the Control Deck Editor

a.
b.
C.

d
e.
f.
9

Exp

Deck Editor: MDK.curr =10 x|

File Edit

Launch ICP beta software by going to the test_scripts directory.
Type run_icpnew_testdata at the command line.

Open the Open Deck Dialog by choosing File = Open... from the ICP Main Window
menu bar.

Select the deck TESTICP - PETE-> MDK - MDK.curr

Note — the Run MCP Automatically checkbox does not need to be checked
Click OK.

Open the Control Deck Editor by choosing Edit - Control Deck

ected Results:

The Deck Dialog appears with the contents of the deck. See screenshot below.

| = # | I B
BLET -
1 1350 12 195% P
DEF-TS =
FLEILD MEE & THETT | §
MAF/FPETERSEN/FLEIA MATOE
FLEILE MAT & THETIT
MAT/FETERSEN, FLEIA MAT
FLEIAERS  RSEL &
FLEIALD RITM &
FLEIAE SREC &
FLEILE ROCL 24
FLEILE SMZC 4
FLEILE INFW &
FLEIRE MALE & THETIT
MAF/FETERSEN,FLEIE MAFOE
FLEIRE MLT & THETIT
MAT/FETERSEN/FLEIE MAT
FLEIBERS  RSEL &
FLEIRE RITHM & —
FLATEE SLEC [ hal
Fun MCP3 automatically
Apply Ok Cancel

Menu_Edit_ControlDeck

B. Verify Scrolling

a.

Scroll up/down

Expected results:

Scrollbar moves to show more on the lower or upper part of the window

C. Dialog closes using X button

a.

Close using the “X” button at the top right hand corner.

Expected Results:

Deck editor closes

29 Version 4.8, ICP Version 1.00.00
9/14/2007



NOAA — National Weather Service/OHD
Interactive Calibration Program — Test Plan and Procedures

D.

Edit a new deck in the Control Deck Dialog

a. Open the Open Deck Dialog by clicking on the open button in the main window toolbar
b. Select the deck TESTICP - PETE - TS - APLOTTS.curr

c. Click OK.

d. Open the Control Deck Editor by choosing Edit = Control Deck.

Expected Results:

- The Control Deck Dialog appears with the contents of the newly selected deck.

Edit control deck and verify changes are not saved

a. Now edit a parameter in the dialog. Find the 4th line of the text displayed in the dialog.
The text is:

PMKIBE MAP 6 INPUT

b. Change the text in the editor by deleting the 6 in this line and typing a 5.
c. Click the X button in the upper right hand corner of the dialog.

d. Re-open the same deck disk by selecting Edit - Control Deck again.
Expected Results:

- Verify that the change was NOT saved to the deck. The 4™ line of text in the dialog
should still be

PMKIBE MAP 6 INPUT

Edit control deck and verify changes are saved

a. Open the Control Deck Editor again by selecting Edit = Control Deck.

b. Find the 4™ line of text in the dialog — it is

PMKIBE MAP 6 INPUT

c. Change the text in the editor by deleting the 6 in this line and typing a 5.

d. Click the Save file button on the toolbar of the Control Deck Editor Dialog.

e. If Run MCP3 automatically is selected, a warning should be generated because the input
is not valid.

f.  Click the X button in the upper right hand corner of the dialog.
g. Re-open the Control Deck dialog by selecting Edit - Control Deck.
Expected Results:

- Verify that the dialog is dismissed after clicking X in the upper-right corner of the
window.

- The 4™ line of text displayed in the editor is
PMKIBE MAP 5 INPUT
Re-set changed value to the original value

a. Change the 4™ line of text displayed in the dialog to its original value. Delete the 5 and
type a 6 in the 4™ line.

b. Click the Save button on the Control Deck Dialog toolbar.

c. Click the X button in the upper right hand corner of the dialog.

Expected Results:

- Control Deck dialog is dismissed.

Control Deck that returns a stop code > 4 can still be opened using the Control Editor

30 Version 4.8, ICP Version 1.00.00
9/14/2007



NOAA — National Weather Service/OHD
Interactive Calibration Program — Test Plan and Procedures

a.

b.
C.

Use the Open tool on the main window to select the TESTICP - PETE-> AFGIX >
AFGIX.errl.

Dismiss the Stop Number Error dialog when it appears.
Select Edit > Control Deck.

Expected Results:

The Control Deck dialog displays the AFGIX.errl deck.

I. Close the Control Deck Editor and the ICP Main Window

a.
b.

Click the X button in the upper right hand corner of the Control Deck Dialog.
Select File > Exit from the ICP Main Window.

Expected Results:

The Control Deck Dialog and the ICP Main Window frame close.

4. SAC-SMA Parameter Dialog
A. Open the SAC-SMA Parameter dialog and verify general layout

a.
b.
C.

Start the ICP beta software by going to the test_scripts directory
Type the following at the command line: run_icpnew_testdata

After the ICP main window appears, select a deck by clicking on the Open toolbar
button.

In the Open dialog, select the deck TESTICP - PETE > AMDK -> AMDK _.curr

Click the OK button. Note — the Run MCP Automatically checkbox does not need to be
checked.

Open the deck by selecting Edit > Control Deck...
Now open the SAC-SMA parameter dialog by selecting Edit > SAC-SMA....

Position the windows so that both the SAC-SMA parameter editor and control deck
editor are visible.

Expected Results:

Verify that the SAC-SMA dialog (and control deeck editors) appear. See screenshot
below for look and feel (values may be slightly different):
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AC-SMA Dperation Editor =10l x|
Operation parameters
FLEIAE FLEIEE
ILET i S0, S0,
I1EF it B0, S0,
Ek, 0,40 0,40
PCT I 0,010 Q.01
ADIMP 0.0 0.0
Rl s, 0,050 0,050
ZPERLC 100, 100,
FEExF 150 1.50
LZT ‘itfh 240, 240,
LZFS 1000 1000
LZFF M 150, 150,
L5k, 0,10 0. 10
LZPF 00040 0,000
FFR.EE 020 0,20
SIDE 0.0 0.0
ET _DEMAMND Curve Curve
PERCOLAT ICMN_DEMARD Perc Perc
Preserve ratio/ diff
Run MCP3 automatically
Apply Ok Cancel
Edit_SAC-SMA

B. SAC-SMA Parameter dialog closes using the X button

a.

Close the SAC-SMA parameter dialog by clicking the upper right-hand X button
Expected Results:

Dialog is dismissed

C. Edit SAC-SMA Parameter

- o o0 T

Open the SAC-SMA parameter editor with Edit>SAC-SMA
Click on the UZTWM PLBIAB cell (first column).
Enter 100 (change the value from 50 to 100).

Press the Apply button.

Press the X in upper right to close the window.
Open the SAC-SMA parameter editor again with Edit->SAC-SMA and inspect the data

values.

Expected Results:
- Value in UZTWM PLBIAB cell is 100.
- The control deck value is also 100 for the operation and parameter in question.

D. Edit SAC-SMA ET Demand Curve by entering value in table

a.
b.

Open the SAC-SMA parameter editor with Edit>SAC-SMA
Click on the Curve button in the first column — the ET/Demand editor dialog should

appear

Click in the cell under “Jan”.
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d. Change the value to .5 — press Enter. The curve should shown the new values in dashed
lines (for both January values that are shown). See figure below.

e. Press the OK button in the dialog to apply the change and close the dialog.

f. Press Apply in the SAC-SMA parameter dialog. If “Run MCP3 automatically” is
checked MCP3 will run and output displays will be updated.

g. Open the curve editor again by pressing the Curve button in the SAC-SMA parameters
dialog.
h. Check that the value for Jan is .5.
i. Press the OK button in the dialog to close.
Expected Results:
- Value in the Jan Cell is .5.
- The parameter values will also be updated if the control deck editor is open.
- Curve shows new Jan values as .5 in dashed lines initially and as solid lines later.

T Demand/PE Adustment Editor =10 x|
ET Demand Curve: PLEIAB

300+
450+
400
3.504
3.00+
2504
2,004
1.504
1.00+
0.50+
.00+

mm/day

T T T T T T T T T T T T
Jan Feb  Mar  Apr May Jun Jul &ug Sep Oct Moy Dec
16th of Month

lan | Feb | Mar | Aor | May | Jun | Jul | Aug | Sep | oct | BMow | Dec | Jan
FE Q50 0400 050 0ad 160l 299 427 2,400 100 050 0.40] O30 0.50

Undo Cell Edit Undo All

Ok Cancel

SAC-SMA_ET_Jan
E. Edit SAC-SMA Parameter by dragging curve.
a. Continue from the previous test.

b. Click on the Curve button in the second column of the SAC-SMA parameters dialog —
the ET/Demand editor dialog should appear
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C.

Press the left mouse button down over the highest point on the curve (Jul) and slowly
drag downwards. The point on the curve will follow the mouse (see image below).

Press the OK button.

Press the Apply button in the SAC-SMA parameters window.

Press the Curve button in the second column for the ET_DEMAND parameter. Verify
that the change is recognized for the PLBIBE operation..

Press the OK button in the curve window.

In the SAC-SMA operation parameters dialog, press OK. If the Run MCP3
automatically checkbox is selected, an MCP3 run will run automatically and the main
WY-PLOT will be updated. The curve edits will only be saved to the deck if Apply or
OK is pressed in the SAC-SMA parameters window.

Expected Results:

Value in Jul cell in the table should adjust as the curve is dragged. See image below.
Note the y-axis is scaled to the new values.

Control deck is also updated.

% ET Demand/PE Adustment Editor
ET Demand Curve: PLEIEE

1 1 1 1 1 1 1 1 1 1 T 1
Jan Feb  Mar  Apr May  Jun Jul Aug Sep Oct bNow Dec Jan
16th of Month

lan | Feb | Mar | Aor | May | Jun | Jul | Aug | Sep | Oct | Mow | Dec | Jan

FE 040 0.50] 070 120/ 2.40| 2. 60[ 405 420 2. &0] 1.20| 0.&0] 0.40) 0.40

Undo Cell Edit Undo All

Ok Cancel

SAC-SMA_ET_DragGraph

F. Test Preserve ratio/diff

a.

Open the SAC-SMA parameter editor with Edit>SAC-SMA

b. Verify that the Preserve ratio/diff checkbox is NOT checked.
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Q —h Do o 0

Change the value of UZK in the PLBIAB column to .8 and press Enter.
Change the Preserve ratio/diff checkbox to be checked.

Change the value of UZK in the PLBIAB column to .2 and press Enter.
Press OK in the SAC-SMA parameter editor dialog.

After verifying the results (below) exit ICP by pressing the upper right X in the main
window.

Expected Results:

- Value in second column for UZK (.1) will be half of that entered in the first column
(-:2)

- Dialog is dismissed

5. View Output Listing Dialog
A. Open the Output Listing Dialog and verify general layout

a.

Q -~ D o o0 o

Start the ICP beta software by going to the test_scripts directory
Type the following at the command line: run_icpnew_testdata
Select a deck by clicking on the Open toolbar button

Select deck TESTICP - PETE - PE > AFGIXPE.curr
Check the “Run MCP Automatically” checkbox

Click the OK button

After MCP has finished executing, open the Output Listing Dialog by selecting the menu
item View - Output Listing...

Expected Results:
The Wide Output Listing Dialog should appear (see screenshot below)

Title bar shows “Output Viewer” and shows the name of the selected deck
“AFGIXPE.curr”

:5?.';555:DutputViewer: AFGIXPE.curr =3 x|
le Edit
sl D
1MWSRFS CALIERATION SYSTEM - PROGRAM MCP2 {VERSION: ob7.2 - 05/19/06) DATE=Mar 28, 2007 - 15:20:58 el
0 =
**********
E AR
***** PLEL E—
E AR
**********
s PERIOD USED FOR THIS RUN -- 1AN/1990 TO DEC/1099 s
**********
E AR
OTIME SERIES USED BY SEGMENT:
L] TIHE DATA TIHE ESP  ESP
SERIES DATA TIME SERIES FILE FILE TS
I TYPE INTERVAL TYPE TYPE TYPE TYPE EXTERNAL INFORMATION
1 _PILEIAE MaP A _HOLRS _ TNPLIT CARD -

View_OutputListing

B. Verify scrollbars are working

a.

Scroll horizontally and vertically (may need to resize window to demonstrate horizontal
scrolling).

Expected Results:
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- Verify that the rest of the dialog can be viewed by scrolling horizontally or vertically.
C. View new output listing in the Wide Output Listing Dialog

a. Leave the output viewer window open.

b. Click the Open Deck (“Select a control deck”) toolbar button to select a new deck.

c. Select deck TESTICP - PETE - TS = TS.curr,

d. The “Run MCP Automatically” checkbox should be checked. Click the OK button.

e

After the MCP has finished executing (MCP Stop Number is 0), the Output Listing
Dialog will display output from the new run.

Expected Results:

- The Output Listing Dialog should correspond to the new deck (look for “PAYI” in
header).

- While running, the output listing window reads “Run MCP3 to generate output listing”
D. Close Output Listing Dialog (X Button)

a. Close the Wide Output Listing Dialog by clicking on the X button in the upper right hand
corner.

Expected Results:
- The Wide Output Listing dialog dismisses

6. WY-PLOT
A. Generate WY-PLOT results and show SAC-SMA Plot

b. Start the ICP beta software by going to the test_scripts directory
Type the following at the command line: run_icpnew_testdata
Select a deck by clicking on the Open toolbar button
Select deck TESTICP - PETE > AFGIX > AFGIX.curr
Check the “Run MCP Automatically” checkbox
Click the OK button

After MCP has finished executing, the WY-PLOT graph will be shown in the bottom of
the main ICP window.

Select the PLBIBE SAC-SMA operation from the choices in the upper left of the main
window.

J. Make sure the Log scale checkbox in the lower left of the WY-PLOT is checked.
Expected Results:

- The main ICP window will show the select SAC-SMA and WY-PLOT output as shown
below.

k. Resize subplots by clicking on small rectangle handles on right side of plot and dragging
to resize the plot.

Expected Results:
- The plots on either side of the divider resize.

SKQ - Do o 0
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E1ce: aFGIx.curr =]
File Edit View Help

alBl @&

Operations : . " - - = T TR
) None : Ra::“r,;\oh"b“ Funotf
SNOW-17 : s0 s oo
) PLBIAB sUR g Ty s wo ' =
O PLBIBE
SAC-SMA ;| RUNOFF

O PLBIAB e
@ [PLEIBE g L=
WY-PLOT

® WY-TOT

Rain

MCP3 Stop Mumber: 4 XWalue: 1171771990 ¥ Value : 10

Main_AFGIX_SAC-SMA

B. Display frozen ground
a. Continue from previous test.
b. Select the PLBIAB SAC-SMA operation from the choices on the left.
Expected Results:

- The main ICP window will show the selected SAC-SMA and WY-PLOT output as
shown below — in this case the frozen ground (Frost Index) graph will be shown at the
top.
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EA1ce: aFGIx.curr

File Edit View Help
=B |2 »

=] B3

Operations

) None
SNOW-17
) PLBIAB

) PLRIBE
SAC-SMA
i® PLBIAB

) PLRIBE
WY-PLOT
® WY-TOT

Frost -1u.uuw |
Index .mnnn

o 1otal
Funoff
a1 MRTGD%

Rain +het " R N | L N e T T H
LR

oo scae <« | S YL P W, " W WY - |

MCP3 Stop Mumber: 4 X Value: 05/19/1990 Y Yalue : 28.64

Main_AFGIX_SAC-SMA_Frozen

C. Display SNOW-17 plots

a.
b.

Continue from previous test.

Select the PLBIBE SNOW-17 operation from the choices on the left. The snow plots
should display instead of the SAC-SMA plots.

Select the PLBIAB SNOW-17 operation from the choices on the left. The snow plots
should update for the selected operation.

Expected Results:

- The main ICP window will show the selected SNOW-17 and WY-PLOT output as
shown below.
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EA1cP: AFGIX.curr =]
File Edit VYiew Help

=B (2>

Operations : Frecip = | — - — _—r — = > = |- Hi% ELEY
) None i fmmi &N fm
SNOW-17 Snow Temp M _ _ | Exchange
®pwag | S
:E e
& Raim <%
1 PLEIBE Bareground
SAC-SMA I T = [ Liaw
(O PLBIAB || MEGHS 200 2 =T (e _
I PLRIRE | e )
i (mm}
_ 2| Snow Depth
WY-PLOT A 500
= WY-TOT
0 -

Cog scae. < T VLN W ™ N WY - |

MCP3 Stop Number : 4 X Yalue: 02/11/1990 Y Value : 48.54

Main_AFGIX_SNOW-17

D. WY-PLOT Plot panner
a. Continue from previous test.

b. The panner window shown at the bottom of the main window shows the visible
extent of the graph. Click with the left mouse button to the right of the highlighted
cyan box.

Expected Results: The cyan box in the panner should move to the next position to the
right of the previous location and the graphs will be updated to reflect the new period
being shown. See below.

c. Click on the right scroll-bar arrow.

Expected Results: The graph should scroll to the right by one day.

d. Hold the mouse down on the right scroll-bar arrow.

Expected results: The graph should continuously scroll by one day at a time.
e. Drag the cyan box in the panner.

Expected results: The graph should scroll as the box is dragged.
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f.  Using the left or right mouse button, click to the right or left of the cyan box in the
panner.

Expected results: The graph should page one screen to the right or left, on the same side
that was clicked.

g. Using the middle mouse button, click in the panner.
Expected results: The graph should reposition to be left-justified on the selected point.
h. Drag the main graph.

Expected results: The main graph will scroll as it is graphed and the panner box will
scroll similarly.

E1cr: aFGIx.curr =]
File Edit Yiew Help

Operations 1: rrecp - l__ T - - i —— L |- % ELEY
) None : fmml  n i fm
SMNOW-17 Snow Terﬁp WN’MM Exchaﬁ;;e
& (deg C) St (FQMNET)
@) PLEIAB 3 S
Opeige | 0
Bareground .
SAC-SMA | o001 e, Aa.“.l‘-_\._.l..Jh — ]l'L <ttt v
1 PLEIAR | MEGHS 200 (iract) _
1 PLEIBE Rl i
_ Snow Depth
WY-PLOT : om 500
® WY-TOT
D 1
o

MCP3 Stop Number: 4

Main_AFGIX_Panner
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E. Log Scale
a. Continue from previous test.

b. Select the “Log scale” checkbox in the lower left of the window, next to the panner.
Expected Results:

The lower (discharge) graph should be redrawn using log scale. Note that the units are also
changed to mm. See below.

E1ce: aFGIx.curr =]
File Edit View Help
AL A
Operations : Frecip = | T - — C i - I- Rdo ELEW
) None S mmian aJ im
- Snou Terﬁp E&cha-nIQe
sc;?:ml;;; | Tean s vea rﬂ/t (PONET)
£ S m
& Raim =%
) PLBIBE | sareground o o
SAC-SMA || e Pt T " uw
5 NEGHS 20.0 B (fract)
O PLBIAB n
C)PLEIBE | WaerE i
H (mm}
WY-PLOT Snow Depth

(cm) - 5004

® wy-TOT /FJ\\

MCP3 Stop Mumber: 4

Main_AGFIX_LogScale

F. WY-PLOT Data Value Display — Mouse-over
a. Continue from previous test.
b. Position the cursor over any point on any time series in the bottom graph.
Expected Results:

The position of the mouse is shown in the lower right and is updated as the mouse
moves.
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G. Placeholder to maintain test numbering

H. WY-PLOT — Change Scale

a.
b.
C.

Continue from previous test (WY-PLOT discharge plot should NOT be in log scale).

Select Edit > WY plot Scale...

In the dialog, change the Duration to 90 days and change the maximum discharge to

100.
Press OK in the dialog.

After verifying the results (below) exit ICP by pressing the upper right X in the main

window.

Expected Results:
- The X and Y axis scales are changed as requested.

WY-PLOT Scale
X-Axis

Duration {days) (max. 3652 an -

Y-Axis

Maximum discharge (CMSD) : |100 ' |

Minimum discharge (CMSD) : C |0 ' |
Apply Ok Cancel

WY-PLOT_Scale

The visible period in the graphs will change to 90 days as shown below:
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E1ce: aFGIx.curr =]
File Edit View Help
a|s| (%
Operations {0 T
o = = — - R ELEY
) None fmm’ = I‘ m o
SNOW-17 Snow Temp - = Exchangs
DETTCI Bk kol
£ S m
: Raim =%
) PLBIBE | baregrouna
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| WEGHS 200 (fract)
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5 (mm}
_ 2| &now Depth
WY-PLOT ©m) 500+
® WY-TOT

MCP3 Stop Mumber: 4

Rain

WY-PLOT_Scale2

I. WY-PLOT — Save and Display SOME

a.

If necessary, restart ICP by running the run_icpnew_testdata script, or continue from
previous tests.

Select deck with the Open (“Select a control deck”) tool and select: TESTICP >
PETE > AFGIX > AFGIX.curr. Make sure that the Run MCP3 Automatically
checkbox is selected and press OK.

After the run is complete, select File > Save all WY-PLOT Time Series

Open the SAC-SMA parameter editor with Edit > SAC-SMA...

Change the UZTWM parameter by a large amount (e.g., from 30 to 300, or the
opposite) and press Ok. MCP3 will rerun and the graphs will redraw.

Load a saved SQME using File > Load Saved Time Series... Select the PLBILOC
SQME time series as shown below and press OK:

43 Version 4.8, ICP Version 1.00.00
9/14/2007



NOAA — National Weather Service/OHD
Interactive Calibration Program — Test Plan and Procedures

Load time series O] x|
Select one time series to display in the WY Discharge plot:
D Twpe Mame Deck, Qperation
PLEITOT CME OBSERYEDTOT |AFCE curr Wy -ToOT
PLEITOT SOME SIMULATEDT OT |AFCE curr Wy -ToOT
PLEILOC SOME SIMULATEDLOC ARSI, curr Wiy =TT
CoC|LAG SOME CoCILAGCED  |AFCE curr Wy -ToOT
Ok Cancel
Load_SQME

g. The graph should update as shown below.

Expected Results:

The previously saved SQME time series will be loaded and displayed as an orange dashed
line with + symbol and be listed in the legend.
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CATCP: AFGIX.curr - O] x
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1

u

Rain

PLBITOT : i

MCP3 Stop Number ; 4

Load_SQME2
J. WY-PLOT - Clear Saved Time Series

a. Continue from the previous test.

b. Clear the displayed time series by selecting File - Clear Displayed Saved Time
Series

Expected Results:

- The SQME time series as shown in the previous test should be cleared from the graph and
the legend.

7. Saving Decks

A. Rename current Deck using Save As
a. Start the ICP beta software by going to the test_scripts directory
b. Type the following at the command line: run_icpnew_testdata
c. Select a deck by clicking on the Open toolbar button
d. Select deck TESTICP > PETE > AFGIX > AFGIX.curr
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e. Verify that “Run MCP Automatically” is checked.
Click the OK button

g. After MCP has finished executing, the WY-PLOT graph will be shown in the bottom
of the main ICP window. The reason that MCP3 must rerun is to update the files in
the MCP3 to ICP interface directory.

h. Save the deck with a new name by selecting File - Save As. Enter AFGIX.test and
press Save. WARNING: for MCP3 the file extension can be no more than 4
characters because of file naming conventions in the MCP3 to ICP transfer directory.
MCP3 will rerun automatically.

i. Edit the deck with Edit - Control Deck.
J. Make a change and save the deck.
Expected Results:
The main ICP window will display AFGIX.test in the title bar.

The file system will show the new file (check in the data directory). Verify that the
new deck is different from the original deck.

B. Archive current deck using Save a Copy
a. Continue the previous test.
b. Save a copy of the file using File > Save a Copy.

c. Enter “AFGIX.copy” for the file name. WARNING: for MCP3 the file extension
can be no more than 4 characters because of file naming conventions in the MCP3 to
ICP transfer directory.

Expected Results:
A file named AFGIX.copy will be created in the MCP3 decks directory.

The main ICP window will continue showing the current file. AFGIX.test in the title
bar.

8. PLOT-TS

A. Verify that PLOT-TS view is disabled when no PLOT-TS operations are present.
1. Open deck TESTICP->PETE->AFGIX->AFGIX.curr and run MCP3.
Expected Results: Verify that the View - PLOT-TS... menu item is disabled.

B. Verify that the WY-PLOT display does not show results when no WY-PLOT operations are used.
1. Openthe TESTICP>PETE->TS-> TS.curr deck and run MCP3.

Expected Results: MCP3 executes successfully but no WY plots should be displayed in the ICP
main window. The View - Plot-TS... menu item is enabled.
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I

File Edit [View | Help
&1 OQutput Listing...

s PLOT-TS...
[J Include Graphs in MCP3 Output File

R

MCP3 Stop Mumber: 4
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C. Verify that PLOT_TS window shows results.

1. Continue the previous test.

2. Select View - PLOT-TS...:

Expected Results: PLOT-TS window opens. The PLOT-PAY operation is selected by default
and displays two subplots with 2 and 3 time series displays in the subplots.

EAPLOT-TS: TS.curr
File Edit

3

PLOT-TS
® PLOT-PAY

PLOT-MDK

Plat 1
(M1
arth

0z 085 10 18 22 28 30 2r 03 07 11 13

01135 0235 03135
« | I o PO U p— »

TS.curr-Plot-TS

D. Verify that WY-PLOT and PLOT-TS operations can both be displayed.
1. Openthe TESTICP>PETE->SCSM8-> SCSM8.smll deck and run MCP3

Expected Results: MCP3 executes successfully and WY plots should be displayed in the main
window. TheView > PLOT-TS... menu item is enabled.

2. Select the PLOT-TS window (and/or position to make visible).
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Expected Results: PLOT-TS window that was previously shown is updated with the SCSM8
plot output. The FIRST operation is selected by default and displays one subplot with 3 time
series.

EAPLOT-TS: SCSMB.smill =]
File Edit

4

PLOT-TS

% FIRST
SECOND
THIRD

Flot 1
[CMS) 50.00
arth

] L
01 05 09
10095 1135 12198

=Tou 4|l [
MCP3 Stop Mumber: 4

SCSM8.smll-Plot-TS
E. Verify PLOT-TS Scrolling
1. Continue previous test with the SCSM8.smll deck.

2. Scroll by clicking on the scrollbar arrows at the edges of the panner window. Hold the mouse
down on a scrollbar to continuously scroll.

Expected Results: The X-axis of the plot shifts by one day at a time to display a different range
of dates.

3. Scroll by clicking in the panner to the right or left of the box.

Expected Results: The X-axis of the plot shifts by one screen at a time to display a different
range of dates.

4. Scroll by holding the mouse down in the panner on either side of the panner box:
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Expected Results: The plot scrolls one screen at a time.
5. Scroll by dragging the panner box to the left or right.
Expected Results: The X-axis of the plot shifts to follow the panner box.

6. Reposition the plot by clicking with the middle mouse button anywhere in the panner
window.

Expected Results: The plot will reposition to be left-justified on the selected point.
7. Scroll by dragging the plot window.

Expected results: The X-axis of the plot shifts quickly and the panner box moves parallel to the
visible period in the plot window.

F. Verify Shifting Between PLOT-TS Operations
1. Continue the previous test with the SCSM8.smll deck and PLOT-TS window open.
2. Switch between the operations displayed in the navigator (FIRST, SECOND, THIRD).

Expected Results: The window updates to display the subplots defined for the selected
operation.

G. Change PLOT-TS Scale
1. Continue the previous test with the SCSM8.smll deck still selected.
2. Choose the FIRST radio button in the navigator. Choose Edit - Plot-TS scale....
Expected Results: The Edit PLOT-TS scale dialog appears

4 Edit PLOT-TS Scale: THIRD

X-Axis
Duration (days) ¢gnax. 2192:  [90| -

Y- Axis

[ Plotl |

Y-Axis

Maximum value :

Minimum value :

[ | Log scale

Apply Ok Cancel

Edit-plot-ts-scale-SCSM8.smll-plot-2
3. Change the duration of the plot from 90 to 730 by changing the “Duration” field. Click OK.
4. Slide the panner to the left edge of the period.

Expected Results: The Edit Plot-TS scale dialog disappears and the dates displayed now range
from 10/98 to 7/00. The panner range (the cyan colored box in the panner) also updates to a
bigger rectangle to reflect the new number of days that are displayed in the main plot.
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5. Select the SECOND operation. Choose Edit > PLOT-TS scale...
6. Change the following for each tab:

a. Onthe “Plot 1” tab, change the maximum value to 60
b. On the “Plot 2” tab change the minimum value to 10 and the maximum value to 40

c. On the “Plot 3” tab click the Log Scale checkbox. Note that when log scale is used,
the plot limits cannot be changed.

d. Click Apply.

Expected Results: The Edit PLOT-TS Scale dialog remains open. The plots change to show the
specified min/max or log scales:

EAPLOT-TS: SC5MB.smll
File Edit
b

PLOT-TS |

) FIRST

® SECOND

) THIRD

LOT-TS Scale: SECOND

Duration ¢days) nax. 2191:  [729
W v-axis

Plotl [ Plot2 [ Plot3 |

V- Axis

Maximum value :
Minimum value :

Log scale

| Aoy | [ ok | | cancer

op Number: 4
100 A718.7010

1) Manthly Subrmittals -
K | i

|Tvpe: Microsoft Waord Dacument Size: 635 KB Date Modified: 9/7/2007 4:47 AM

635 kB [&J Local intranet

Edit-multiple-plot-ts-scales
7. Move mouse over the different plots.

Expected results: Verify that the date and value information displayed in the lower right hand
corner of the status bar is correct, for plots showing log or linear scales.

8. Inthe Edit PLOT-TS scale dialog, change the duration to 365.
9. Press OK.
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Expected Results: The PLOT-TS scale window closes. The plot now shows dates 10/98-10/99.
The panner range (the cyan colored box in the panner) updates to show a smaller colored
rectangle for the new dates that are displayed.

H. Save Time Series and Load to Display
1. Continue using the SCSM8.smll deck.
2. Select the THIRD operation if not already selected.

3. Save the time series by selecting File > Save the Time Series for selected PLOT-TS subplot.

Expected Results: Saving of time series succeeds. The PLOT-TS status area will display “Save
Time Series: Successful”

4. Still looking at THIRD operation
5. Load a saved time series by selecting File-> Load Saved Time Series....
Expected Results: The Load Saved Time Series dialog appears.

oad time series
Select one time series per PLOT-T5 subplot to display:

In] Tuwpe MHame Deck. Cperation
MOCMERETD 50N 3 _HOUR SCEME sl |third
TERELMGUA, QI TERLIMCUA |SCEME smill [third

Plot 1 5C5MELD SN 1_HOUE SCEME smill [third
ECSME ik & _HOUFR SCEME smill [third
SCEMEUP SN 12 _HoOUR  |5CEME smll (third
SCEMETOT |[S0IrM 24_HOURE  |SCEME smill [third

0Ok | Cancel |

Load-time-series-dialog
6. Select the time series with the ID “6_HOUR” (as shown above).

Expected Results: The selection is highlighted in the table. Note: Only one time series can be
selected at a time in the table. The OK button is enabled after a selection is made.

7. Click OK. Expected Results: The plot updates to display the selected saved time series as an
orange dashed line, and the legend updates to show the saved time series. Note that since
parameters were not changed, the saved time series will display on top of another time series.
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EArLOT-15: sC5M8.5mll
File Edit

4

=] B3

PLOT-TS
FIRST
SECOND
% THIRD

Flot 1
[CMS) 50.00
arth

11498 1298 1489 2/99 3/99

oIn - .
Save Time Series: Successful

Plot-TS-displaying-saved-time-series

8. With the THIRD operation still displayed, and the saved time series displayed, select File >
Clear Displayed Saved Time Series....

Expected Results: The plot updates and clears the saved time series from the plot.
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EAPLOT-TS: SC5MB.smil =]
File Edit

4

PLOT-TS |
FIRST
SECOND

® THIRD

Plat 1
(CKS) 50.00
arth

11598 1288 189 2/99

Save Time Series: Successful

Plot-TS-clear-saved-time-series

I. Change Time Series Used in the PLOT-TS Panner
1. Continue with the SCSM8.smll deck THIRD operation.

2. To change the time series displayed in the panner/scrollbar, select File - Change Panner
Time Series....

Expected Results: The change panner time series dialog appears displaying the subplots and
available time series for the selected operation.
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J.

hange Panner time series !EI

Choose a time series
to display in the panner:

Plot 1
3 TERLNGUA - QIN

) SCSMBLO - SQIN
) MGGMSRTD - SOQIN
) SCSMS8 - QIN

) SCSMSUP - SQIN
® SCSMETOT - SQIN
Al

Ok Cancel

Change-plot-ts-panner-timeseries

3. Select the “SCSM8TOT - SQIN” radio button under the Plot 1 heading (as shown above).
Click OK.

Expected Results: The panner image updates to show only the SCSM8TOT — SQIN time series.
+ | v
Panner-with-one-time-series

4. Scroll by clicking the arrow buttons on the left or right side of the panner.

Expected Results: The plot X-axis shifts by ~ 1 day up or down.

5. Scroll by pressing and holding down the arrow buttons on the left or right side of the panner.
Expected Results: The plot X-axis continuously scrolls left or right.

Verify Automatic Update of PLOT-TS Window

1. Leave the PLOT-TS window open but go back to the ICP main window. Choose a different
deck by selecting File > Open... Choose the TS/TS.curr deck. Click OK. Run MCP
(manually or automatically).

Expected Results: The PLOT-TS window automatically updates to display the most recent
PLOT-TS results
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EAPLOT-TS: TS.curr =]
File Edit

4

PLOT-TS ;
8 PLOT- PAY
PLOT-MDK

Plot 1
(M
arth

PATIINF : QME
MCP3 Stop Number : 4

TS.curr-Plot-TS

9. Editing Percolation Curve

A. Open the Percolation Analysis Editor and verify general layout.
a. Select the deck AFGIX.curr (TESTICP - PETE > AFGIX > AFGIX.curr)
b. Open the parameter window with Edit > SAC-SMA....

c. Click the Perc button on the PLBIAB column to open the Percolation Analysis
window.

Expected results: The window should display similar to the following, with the
operation name in the upper left and the tabular parameters matching those in the control
deck):
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ercolation Analysis Editor

PLEIAE
Annotations
1200.00 - Click on graph
" to add a point
100000 4 - Click on point
e 1o remove
E
& o00.004 e
£ L
g ",
.
£ 600.00+
E e
] ey
E 400,00 “*$____....
o .
200,00 T
T
i
Q0 fF===F===F===F===F3===g===3===g===S5===5===5
1.0 na 0s oy 0E 0s 0.4 03 0z 0.1 0.0
Lower Zone Deficient Ratio (LZDEFR) Clear points

Mumber | ZPERC | REXP | LZFSM | LZFFM | LZSK LZPK. Shiow
1 100, 150 100.0 150, 0.10| 00040 Add curve

Run MCP3 automatically

‘ Apply || Ok || Cancel

Percoloation_Analysis_Editor0

B. Verify that a new set of parameters can be added:

a. Continue the previous test.
b. Click “Add curve” to add a row the table.

Expected Results: A row will be added at the bottom of the table with the same values as
the previous last row. An additional curve with the same data points as those
corresponding to the previous last row will be drawn on the graph.
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Percolation Analysis Editor

PLEIAE
Annotations
1200.00 - Click on graph
to add a point
1000.00 - Click on point
to remove
=
S &00.004
E
[T}
=
.E G00.00
E
Q
2 400004
[
=9
200,004
I:II:“:I T T T T T T T T T
1.0 na 0s oy 0E 0s 0.4 03 0z 0.1 0.0
Lower Zone Deficient Ratio (LZDEFR) Clear points
Mumber | ZPERC REXP LZF5M LZFPM LZ5H LZPE show
1 100, 150 100.0 150, 010 00040 ¥ Add curve
2 100, 1.50 100.0 150, 0100 00040 v] Delete
Run MCP3 automatically
‘ Apply || Ok || Cancel

Percolation_Analysis_Editor_New

C. Verify that the selected row is highlighted by a blue rectangle.

a. Continue the previous test.

b. Select the first row.

Expected Results: The selected row will have a blue rectangle around the cells.

D. Verify that the display of a curve resulting from a parameter set can be selectively displayed.

a. Continue the previous test.

b. Click on the checkbox in the “Show” column in the second row (the first row is

always shown).

Expected Results: When the check is displayed in the “Show” column a curve will be
displayed. If the check is not displayed, then the corresponding curve will not be

displayed

E. Verify that a parameter set can be deleted

a. Continue the previous test.

b. Click on the “Delete” button in the second (new) row.

Expected Results: The row containing the “Delete” button and the corresponding curve

will be removed.

F. Verify that parameters can be edited.
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a. Continue the previous test.
b. Press Cancel in the Percolation Analysis Editor to close the previous window.

c. Press Perc in the SAC-SMA editor (first column) to restart the Percolation Analysis
Editor window.

d. Press Add Curve to create a new curve.

e. Click in a cell in the new curve and change data values. For example, change
LZFSM from 100 to 80. Press Enter or tab when editing values.

Expected Result: The curve shape will change, as shown in the following figure (the
original curve will continue to be displayed):

Percolation Analysis Editor

PLELAE
Annotations
1200.00 - Click on graph
. to add a point
1000001 - Click on point
o 10 remove
=
§ 50000
=
[]
=
.5 B0 .00
E
[=]
2 40000+
[1]
o
200,00 4
I:II:":I T T T T T T T T T
1.0 ns 0s oy IR 05 0.4 03 nz 01 oo
Lower Zone Deficient Ratio (LZDEFR) Clear points
Mumber | ZPERLC FEXF LZF5h LZFP M L75k, LZPE. show
1 100, 1.50 1000 1510, Q.10 00040 ¥ Add curve
2 100, 1.50 0.0 1510, 010 0.0040 v Delete

Run MCP3 automatically

| Apply || 0Ok || Cancel

Percolation_Analysis_Editor
f. Select the second row.
g. Press Apply to save the results and cause MCP3 to be run.

Expected Result: The SAC-SMA parameters will be updated based on the values in the
percolation analysis window (for the selected row), MCP3 will run, and output plots will be
updated reflecting the changes.

G. Verify that when out-of-range values are entered a range message is displayed.

a. Enter a value of —10 for ZPERC in the second row and press Enter.

Expected Result: A warning will be shown that the value must be >= 0.
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b. Change the value of ZPERC back to 100 and press Enter or press Esc.
Expected Result: The value will be accepted as valid.

H. Verify the Percolation Demand corresponding to a time can be displayed.

a. Continue the previous test (the Percolation Analysis Editor should be displayed).
b. Select the PLBIAB SAC-SMA operation in the navigator on the main window.

c. (Left or right) click in the WY-PLOT discharge plot at a point of interest. The date
associated with the click is used to determine the point on the percolation curve.

Expected Results: The corresponding point will be indicated by intersecting red lines on
the Percolation Demand curve for the selected row.

ercolation Analysis Editor

PLEIAE
Annotations
1200.00 - Click on graph
to add a point
1000.004— - Click on point
to remove
=
S &00.004
E
[T}
=
.E G00.00
E
Q
2 400004
[
=9
200,004
I:II:“:I T T T T T T T T T
1.0 na 0s oy 0E 0s 0.4 03 0z 0.1 0.0
Lower Zone Deficient Ratio (LZDEFR) | Clear points
Mumber | ZPERC REXP LZF5M LZFPM LZ5H LZPE show
1 100, 150 100.0 150, 010 00040 ¥ Add curve
2 100, 1.50 B0 150, Q.10 00040 v Delete |

Run MCP3 automatically

‘ Apply || Ok || Cancel

PercolationAnalysis-with-cross-hair.png

60 Version 4.8, ICP Version 1.00.00
9/14/2007



NOAA — National Weather Service/OHD
Interactive Calibration Program — Test Plan and Procedures

. Verify that annotation points can be displayed.

a. Continue the previous test (the Percolation Analysis Editor should be displayed).
b. Click on the graph to add points, which are used to construct a target curve.

Expected Results: The graph will display the points as shown below

Percolation Analysis Editor

PLEIABE
Annotations
1200.00 - Click on graph
" 10 add a point
1000004 o - Click on point
e 10 remove
T -~
& o00.00 o
£ . ©
a
s
g 60000 ~
-] s
L 1"“--H__ o
& 40000 .
g ~ o
200.00 :
plF=———y=——==F===F===3g===3===3=
1.0 049 0.a or oG 05 04
Lower Zone Deficit Ratio (LZDEFR) | Clear points
mHumber | ZPERC F.EXP LZF5M LZFP LE5k. LZPE, Show
1 100, 150 100.0 150, Q.10 2.0040 Add curve
2 80, 150 100.0 150. 010 0.0040 Delete |

Run MCP3 automatically

‘ Apply || Ok || Cancel |

Percolation_Analysis_Edit_WithPoints

J.  Verify that annotation points can be cleared.

a. Click on an individual point to clear a single point.
b. Click on the Clear points button to clear all points.
Expected Results: The percolation curve graph will be cleared of annotation points.
10. Editing SNOW-17 Parameters
A. Open the SNOW-17 Parameter dialog and verify general layout.
d. Select the deck AFGIX.curr (TESTICP > PETE > AFGIX > AFGIX.curr)
e. Open the parameter window with Edit > SNOW-17...
Expected results: Window should display similar to below.
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SNDW-17 Dperation Editor =10l x|

Operation parameters

FLEIAE FLEIEE
SCF 1.0 1.0
P F o 2 0,70 0.7
P FiA | 1] 025 025
[t F 0,15 015
WFAR] 0.0l 0.0z
5l GO0, 0 2000
Doy S 030 035
MEBASE 0.0 0.0
FHTEMP 050 0.50
PLutfHZ .02 0,02
TIF M 0.]_@ 0. 10
AREAL_DEPLETIOM Curve Curve
Preserve ratio/ diff
Run MCP3 automatically

Apply Ok Cancel

Edit a parameter in the table & verify.

a. Continue the previous test.

b. Enter a value for SCF (change 1.0 to 0.5 in first column).

c. Press OK to close the window.
d. Reopen the parameter window with Edit > SNOW-17
Expected results: The edited value should be shown

. Verify that pressing ESC in a data cell restores the value.

SNOW_Operation_Editor

a. Continue with the previous test (open SNOW-17 editor if not already shown).

b. Enter a value of 2 in SCF cell in first column. DO NOT press enter.

c. Press ESC.

Expected results: The value in the cell should revert back to the previous value.

. Verify that when out-of-range values are entered a range message is displayed.

a. Enter a value of —1 for SCF in the first column and press Enter.

Expected result: A warning will be shown indicating that the value must be greater than
zero and less than 999.9.

b. Enter a value of 1 for SCF in the first column and press Enter.

Expected result: The correct value will be accepted.

Test Preserve ratio/diff
a. Continue previous test.

b. Verify that the Preserve ratio/diff checkbox is NOT checked.
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c. Change the value of SCF in the PLBIAB column to .5 and press Enter. Only the edited
value should change. Change the value in the PLBIBE column to 1.

d. Change the Preserve ratio/diff checkbox to be checked.

e. Change the value of SCF in the PLBIAB column to .2 and press Enter. The value in the
PLBIBE column will change to .4 (twice that of the first value).

f.  Press OK in the SNOW-17 parameter editor dialog.

Expected Results:

- Value in second column for SCF will be twice that entered in the second column.

- Dialog is dismissed.

11. Editing SNOW-17 AESC Curve

A. Open the AESC Editor by clicking on a “Curve” button in the SNOW-17 Parameters dialog

and verify general layout.

f. Select the deck AFGIX.curr (TESTICP - PETE - AFGIX - AFGIX.curr)
g. Open the parameter window with Edit > SNOW-17...

h. Press the Curve button in the first column.

Expected results: The AESC curve editor should display similar to the following:

AESC Editor

Areal Extent of Snow Cover: PLEIAE

1.0
0.9+
0.5+
0.7+
0.6+
0.5+

WE/A(i)

0.4+
0.3+
0.2+
0.1+

a0 G0
Areal Extent of Snow Cover {percent)

o

a0

100

0o | el | a2 | a3

0% | 06

0.7

1.0

AFSCES 5.00/21.00/ 36 0047 00/58.00

GEO0|73.00

81.00

95.00

100.00

Ok

Cancel
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B. Edit a parameter in the table & verify that the data point on the curve updates.

a. Continue the previous test.

AESC_Editor0

b. Change the Y-axis WE/A(i) value by changing the table value under 0.3. For
example, click in the cell and enter 55, press Enter.

Expected result: The graph will change in response to the cell edit, as shown below:

real Extent of Snow Cover: PLELAE

1.0
0.9+
0.3+
0.7+
06+
0.5+

WE/A(i)

0.4+
0.3+
0.2+
0.1+

70 a0 =11
Areal Extent of Snow Cover {percent)

100

Do [0l | 02 | 0.3

0.4

05 | 06 | OF | 08 | 0.9

1.0

AESCE 5.00/21.00/36.00|55.00

S8.00

66.00|72.00|51.00|89.00(95.00

100,00

Undo Cell Edit

Undo All

Ok

Cancel

c. Press OK to save the result.

Expected result: The AESC curve window closes.

AESC_Editor

d. Press Apply in the SNOW-17 parameter window to apply the changes and run

MCP3.

Expected result: The new output will be shown in plots.

C. Edit a parameter by dragging symbols to right or left & verify that the corresponding table

cell updates as the point is being dragged.

a. Continue the previous test.

i. Open the parameter window with Edit > SNOW-17...

b. Press the Curve button in the first column.
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c. Selecta point and drag (for example, see the following example).

Expected result: As the point is dragged on the graph, the corresponding value will be
updated in the table.

AESC Editor
Areal Bxtent of Snow Cover: PLELAB

1.0
0.9+
0.8+
0.7+
06+
0.5+

WE/A(i)

0.4+
0.3+
0.2+
0.1+

Areal Extent of Snow Cover {percent)

go

a0

100

0.2

0z | 0.4

05 | 08

0.7

0.8

0.9

1.0

AESCE

4791

S5 00J58.00

EE 007300

51.00

89,00

35 00

100,00

Undo Cell Edit

Lndo All

Ok

Cancel

d. Undo the most recent change by pressing the Undo button.

Expected result: The data will revert to the previous values.

e. Make several edits in the table and/or by dragging points.

f.  Undo all changes by pressing the Undo All button.

AESC_Editor_Drag

Expected result: The data will revert to the original values when the curve was first
opened.

12. Editing UNIT-HG Parameters

A. Open the Unit Hydrograph Editor and Verify Layout

a. Select the deck AFGIX.curr (TESTICP - PETE - AFGIX - AFGIX.curr)
b. Open the parameter window with Edit > UNIT-HG...
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Expected Results: The UNIT-HG parameter window will be shown similar to below. Note
that all fields are disabled because editing occurs through the curve.

% UNIT-HG Operation Editor -10| x|
Operation parameters

IH-LOCAL AREA
# of Ordinates 10
Titne Step (hrs) 3
IHG Curve
Close

UNIT-HG_Editor0

c. Open the UNIT-HG curve window by pressing the Curve button in the UNIT-HG
parameter editor window

d. Expected Results: The UNIG-HG curve editor window will be shown similar to below.
Verify that the first and last cells are grayed out indicating they are not editable. Using
the deck editor, review the UNIT-HG operation definition and verify that the ordinates
agree with the deck.

Unit Hydrograph Editor

Unit Hydrograph: UH-LOCAL AREA

S000.00

4500.00
4000.00

3500.00 4
3000.00 4
2500.00 4
2000.00

Discharge {cfs)

1:500.00 4
000,00
S00.00

0.0a

T T
1 3 G g 12 14 15 2 24 2 30 33
Time (hours)

0] 3 ) 2] 12 15
Cischarge 000 1000 00 2000 Q0 200000 4000 00 400
4] Il | [»

Indo Undao All

Run MCP3 automatically

Apply Ok Cancel

UNIT-HG_Editor
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B. Edit a coordinate in the table & verify that the data point on the curve updates.

a. Continue from previous test.

b. Edit values in the table. Press Enter after each value. Note that the entire curve will
adjust, not just the single point.

Expected Result: The graph will update to display the updated values.
c. Press Apply to save changes.
Expected Result: MCP3 will run and the plot output will be updated to reflect results.

C. Edit a parameter by dragging symbols up or down & verify that the corresponding table cell
updates after the drag is completed.

a. Continue previous test (the UNIT-HG Curve window should be open).

b. Drag a point vertically to change the curve shape.

Expected results: The curve will adjust to respond to the new data.

c. Press Apply to save results.

Expected Results: MCP3 will rerun and display output corresponding to the new values.

D. Verify that Undo reverts a data cell to the original value and reverts the curve data point.

a. Continue the previous test.

b. Press Undo Cell Edit. Expected results: The curve should revert to its values prior
to the previous edit.

E. Verify that Undo All reverts all data cells and curve data points to the original values.

a. Continue the previous test.
b. Press Undo All . Expected results: The curve should return to its original shape.

F. Verify that all columns of the table can be displayed by scrolling.

a. Use the scrollbar handle to scroll through all the unit hydrograph data. Expected
results: The number of ordinates in the unit hydrograph table + 2 should be visible,
with the zero endpoints being non-editable.

G. Verify the functionality of automatic slope calculation.

a. Edit any point to the left of the last editable point.
b. Edit any point to the right of that point.

Expected Result: Any intervening points between the edited points will be adjusted to
lie on a straight line between the edited points.
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B.2. Regression Tests

Note that this type of testing was not originally scoped but some work was done to investigate
regression testing, in order to automate testing. However, project resources have not been
sufficient to fully implement this approach. The following documentation is provided to allow
for possible implementation in future enhancements to ICP.

A list of regression tests will be provided once GUI features become static, and will be made
available for final acceptance and integration testing. It is envisioned that key test cases as described
in the previous section will be automated by using the Abbot/Costello software and will therefore
allow NWSRFS developers/maintainers to verify ICP functionality without depending on interactive
tests.

B.3. Unit Tests

Unit tests are implemented within the ICP developer sandbox during each software release iteration.
Because ICP is being developed in a test-driven fashion, unit tests are an integral part of
development. Unit tests are not listed here but are visible in the Eclipse project and can be run using
the Ant “test” target. Developers should define unit tests consistent with Eclipse and JUnit standards.

A list of unit tests and output can be provided for final delivery. Performing a clean compile of the
ICP software will clearly indicate when unit tests fail because targets to run the software and build
installations is dependent on unit test targets.
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