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Introduction

This is intended to be an introduction/refresher to the GR2A program. It

doesn’t cover every single feature, but hits on those that are the most

useful. This manual was made for GR2A 2.90. Previous versions of GR2A

2.x, GR2/GR2A 1.x, and GR3 have similar interfaces, but may differ in

sometimes substantial ways or be missing features.

Hopefully you can glean some new information and tricks on using GR2A

from this presentation. With the right setup, GR2A can be a very powerful

program.

NOTE: As of May 2020, GR now supports Level II TDWR data.

However, the nationwide data feed is not fully implemented. Data

will not be available for all sites until this is completed. GR has the

option to check for live data availability and will highlight which

TDWR sites are available—see this section for more info.
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If you are installing GR2A for the first time on your computer, you 

will likely see a pop-up box appear when you first launch the 

program asking which Level II data feed to use (see screen 

capture below). 

First Time Use
Level II Data Feed

Table of Contents

Unless you have a different feed to 

use, it is easiest to choose the Iowa 

State L2 feed (first option). You can 

always change these settings later 

in the File -> Configure Polling

menu item.



Program Layout
Overview (Default Layout)

Menu Bar Toolbar

Color 

Table

Radar Display Window Status Bar

Product 

Information



• Menu Bar

Access to almost all of the settings for GR2A

• Toolbar

Shortcuts to the most common options (polling, animation, 

viewing options, storm motion, icons, and warnings). 

Mousing over each button gives its description.

• Color Table

Scale for the currently displayed or selected product

• Radar Display Window

Displays the currently loaded data

Program Layout
Component Descriptions



The Product/Tilt Window can 

be toggled on and off by going 

to Windows ->Show Product /Tilt 

Window.

The window shows the available 

radar tilts and other valuable VCP 

information in one place. When 

toggled off, much of this info 

shifts to small boxes placed in the 

four corners of the Radar Display 

Window.

Program Layout
Product/Tilt Window

Product/Tilt Window Toggled Off
“Four Corners Layout”

Product/Tilt Window Toggled On
(Right Side of Window)

Site & VCP

Product & Tilt

Storm Motion

Volume Start Time & 

Product Time

Descript ion of the Product/Ti l t  

Window on Next Page



Shapefile Data 

at Cursor 
(ex. Road Name)

Cursor Azimuth 

and Range from 

Marker/Radar

Cursor Readout / 

Max Unambiguous 

Velocity (V/SRM only)

Cursor 

Coordinates

Height of Radar 

Beam at Cursor (ARL)
Live Data 

Polling Status & 

Update Time

Product/Tilt Window

Site ID & MESO-SAILS or MRLE 

scanning strategy in use, start time 

of the volume scan and product, 

VCP, and the user-set storm motion

Available products

Available tilts to choose from. If a * 

appears next to the tilt, the data is 

from the previous volume scan.

Radar Display 

Window Resolution

MESO-SAILS 

or MRLE scans

Program Layout
Product/Tilt Window & Status Bar

Status Bar

If AVSET is Enabled

MESO-SAILS & MRLE Display Notes

When GR displays the text “SAILS_x”, x is 

the number of additional 0.5° slices being 

scanned. This number ranges from 1 to 3.

For the text “MRLE_x”, x is the number of 

additional low-level tilts being scanned. 

MRLE_2 = 0.5°, 0.9°

MRLE_3 = 0.5°, 0.9°, 1.4°

MRLE_4 = 0.5°, 0.9°, 1.4°, 1.8°

MESO-SAILS and MRLE cannot be used 

concurrently. If no text is displayed, neither 

scanning strategy is being used.

http://glossary.ametsoc.org/wiki/Maximum_unambiguous_velocity


Radar data can be viewed in one, two, or four panels in the 

Radar Display Window.

Program Layout
Panels

Panels -> Four Panels  

to view four panels in the window

Panels -> One Panel  

to view one window

Panels -> Two Panels  

to view two panels side by side



• To add a product to each panel in the two or four panel 

layout, click the panel—it becomes highlighted with a thin 

black box—and choose the desired product and elevation 

from the Product/Tilt Window or Menu Bar.

• Pre-built panels are also under the 

Panels menu. Up to 8 different layouts 

can be edited and saved using the 

Panels -> Save Current Panels as

option in the menu.

Each panel is numbered 1-8. To open a 

panel, choose it from the list under the 

Panels menu or select the corresponding 

number from the keyboard/keypad.

Program Layout
Panel Editing

Table of Contents



• To change the current site, go to Site -> Select…

– Choose your site from the list that opens and click OK.

Sites that begin with the letter “T” are TDWR sites.

– You can also change to a nearby site by clicking on 

the radar ID in the Radar Display Window.

• To change the startup site

– Go to Site -> Settings…

– In the Startup Site box, click Change 

and select the site from the provided list

– To have GR2A begin polling this site 

at startup, check the box below the 

site selection field

– Click OK once done

Radar Site Settings
Changing Current & Star tup Sites



• User-defined favorite radars are displayed in the 

Site menu
Sites are displayed in alphabetical order by site ID

• To configure Favorites:
– Go to Site -> Settings…

– In the Favorite Sites box, click Add

– Select the site from the list and click OK

You will have to do this for each site

– To remove a site from your favorites, select

the site from your list and click Remove

– Click OK in the Site Settings box when done

Radar Site Settings
Favorite Sites

Table of Contents

To add the currently displayed radar site as a favorite, go 

to Site -> Add to Favorites



• To start downloading live data
– Click the Start Polling button        on the Toolbar

– Note: A polling site must be configured beforehand, either when the 

program was first set up or via the Configure Polling setting

• To load previous volume scans

– Click the Download Recent Data button        on the Toolbar

– To configure how many volume scans GR2A downloads and how 

often it polls for data, see the Configure Polling section

• To stop live polling without shutting GR2A down

– Click the Stop Polling button        on the Toolbar

Loading Radar Imagery
Live Data



• Navigate to File -> Configure Polling…

You cannot be downloading live data while changing these options

• The window that opens up will display the sources of Level II data. The 

buttons on the right allow you to add/remove new sources and change 

their priority (top source is used first).

• There are three configurable options on the bottom:

– Polling Interval: How often GR2A

checks for new radar data

– Retain files for: How long GR2A will

keep the files it downloads before

discarding them

– Keep in memory: How many scans

GR2A will keep in memory that will

be available for animating

Loading Radar Imagery
Configure Polling (Advanced Users)



As of April 2020, GR2A supports the use of TDWR data, though Level II 

data is not flowing from all sites. 

Loading Radar Imagery
TDWR Data Availability

• To alert users to whether data is available for a 

site, there is an option called Automatically 

Refresh Sources in the Configure Polling window. 

This is DISABLED by default. If you plan to use 

TDWR data, is would be beneficial to have this 

setting turned on until all sites are transmitting 

Level II data. 

• By enabling it, GR2A will refresh its radar site list 

when the program launches, removing sites that 

are not available from the Site menu and 

greying them out on the Radar Display Window.



• In Menu Bar go to File -> Open…

Navigate to the folder containing the data, 

use the shift key to highlight the desired time 

range, then click open

• You can also drag and drop the radar 

files you wish to load directly from the 

Windows Explorer into GR2A.

• A maximum of 24 radar files can be 

loaded into the program at one time.

Loading Radar Imagery
Archived Data

Table of Contents

Depending on the size of the radar files and the computer 

hardware, the dataset may take over a minute to load. This is 

especially true for files containing MESO-SAILS or MRLE data!



The Toolbar contains the animation controls for looping data

To control looping speeds, see the Editing Settings section

First Image in 

Sequence Last Image in 

Sequence

Play/Pause Loop

Previous Image
Next Image

Navigating Radar Data
Animation

Shortcut: You can also step through the images by using the left and 

right arrows on the keyboard. The spacebar activates/stops looping. 



• To Zoom (Three Options)
1. Use your scroll wheel to zoom into where ever your mouse is 

located on the Radar Display Window.

2. Right-click & hold on an area in the Radar Display Window and 

drag outwards, forming a box that GR2A zooms in to.

3. Use the zoom controls on the Toolbar (below): 

• To Pan
Click the      button on the Toolbar, the click and drag on the Radar 

Display Window to move the image around. You will need to select 

this option when exiting from Cross Section or Volumetric mode.

Zoom In

Zoom Out

Zoom Completely Out

Navigating Radar Data
Zooming & Panning



GR2A calculates a number of Level III products using Level II data

Product Notes

– An extra dual-pol product is available in GR2A that is not viewable elsewhere. This is 

phase shift, or PHI. This is the differential phase shift product before a distance 

derivative is applied to the data

– Hydrometeor Classification Algorithm is listed as a product in GR2A, but is currently 

not available. 

Level II Products Ingested by GR2A Level III Products Produced by GR2A

• Base Reflectivity (BR)

• Base Velocity (BV)

• Spectrum Width (SW)

• Differential Reflectivity (ZDR)

• Correlation Coefficient (CC)

• Phase Shift (PHI)

• Differential Phase Shift (KDP)

• Storm Relative Velocity (SRM)

• Echo Tops (ET)

• Vertically Integrated Liquid (VIL/DVIL)

• Probability of Severe Hail (POSH)

• Maximum Estimated Hail Size (MEHS)

• Normalized Rotation (NROT)

• Hydrometeor Classification Algorithm (HCA)

Navigating Radar Data
GR2A Radar Products

Descript ion of the Precipi tat ion Type Product on Next Pages

Not Available 

with TDWR Data



Using RAP model data, GR2A calculates the expected type of 

precipitation reaching the ground in areas with radar echoes.

To view this imagery, ensure that base reflectivity is loaded and then 

select the      button on the toolbar. The reflectivity imagery is 

colorize by four main p-types:

1. Liquid

2. Freezing Rain

3. Sleet

4. Snow

To view the raw base reflectivity data again, deselect the      button. 

You can view other base products except base reflectivity with the 

button toggled on.

Navigating Radar Data
Precipitation Type

1

2

3

4



Please keep the following items in mind when using this product:

• This data is derived STRICTLY from the RAP forecast model. Surface 

observations are not incorporated into the calculation.

• Data is only available for CONUS real-time radar viewing. Precipitation 

type is not calculated for archived datasets or OCONUS regions 

(model data is not available).

• This is NOT the same as the HCA product 

available as a Level III product. The HCA 

calculates the characteristics of the precipitation

sampled by the radar beam at each elevation 

angle, while the Precipitation Type algorithm 

calculates the expected precipitation type at 

ground level.

Navigating Radar Data
Precipitation Type Caveats 



Ways to change products and elevation angles:

• Click the desired product & tilt on the Product/Tilt Window

• Choose the desired product & tilt from the Menu Bar

• Tilt Only : Use the up and down arrow keys on the keyboard to 

progress up and down through the volume scan.

• Product Only: Use the keyboard shortcuts for each product. The 

keys that correspond to each product are underlined in the Product 

Information panel (image below, right)

Menu bar items for choosing products 

Navigating Radar Data
Changing Products & Elevation Angles

If a * appears next to the tilt, the data is from the previous 
volume scan.

1
2

1

2



To set the storm motion manually

– Click the       icon in the Toolbar.

– A window will pop up allowing you to 

enter the storm’s motion and speed. 

Navigating Radar Data
Setting Storm Motion Pg. 1 of 2

To have GR2A calculate the storm motion

1. Right-click in the middle of storm (or edge, as 

long as you are consistent in step 3) and set a 

marker there.

2. Advance several frames forward or backward.

3. Right-click on that region of the storm again 

and in the menu that opens up, select 

Storm Motion from Marker.

(Note: Storm motion should be the direction the storm is COMING from)



Storm Track

To set the storm motion from NWS warnings

Right-click the warning polygon and select 

Storm Motion from Warning from the menu 

that appears

GR2A can show a one hour predicted storm track based on the set storm motion with 

15 minute increments highlighted.

To Add: Right click on storm 

and click Storm Track Here 
To Remove: Right click and 

click Remove Storm Track

Navigating Radar Data
Setting Storm Motion Pg. 2 of 2



To sample radar data 

at the location of the 

mouse, either 

reference the status 

bar at the bottom of 

the window or hold 

down the ctrl key, 

which will open up a 

small box next to 

your mouse arrow 

with the product 

value and elevation 

above the ground.

Navigating Radar Data
Sampling & Rotational Info (Advanced Users)

Table of Contents

To conduct a detailed interrogation of a rotational couplet, 

zoom into the couplet on radar.  Set a marker on either the 

max inbound or outbound velocity value of the couplet and, 

while holding down the ctrl key, sample the opposite max 

value of the couplet.  The pop-up window below appears. 

Window Components

Sampled Velocity / Max Unambiguous Velocity (kts)

Sampled Beam Height (ARL)

------------------------------------------

Velocity Inbound (kts)   Velocity Outbound (kts)

Velocity Difference (kts)    Diameter of Couplet (nm)

Azimuthal Shear (0.001 * s-1)

Rotational Velocity (|Vin|+|Vout|/2) (kts)

Conditional Tornado EF-Scale Probability using Vrot

values in case studies from 2009-2013. Please read 

the article to use this technique properly!

http://glossary.ametsoc.org/wiki/Maximum_unambiguous_velocity
https://vlab.ncep.noaa.gov/web/wdtd/-/azimuthal-she-1?selectedFolder=562123
http://www.spc.noaa.gov/publications/smith/vrot-env.pdf


Turn on/off radar 

data in display 

window

Toggle the GR2A 

calculated  

TVS/Meso icons

Toggle the GR2A 

calculated hail 

size icons Toggle NWS Local 

Storm Reports (LSRs) 

icons (for the last hour)

Show Precipitation Type

Panel center icon– for 

2 and 4 panel layouts 

(useful for correlating 

data between panes)

Overlays
Toolbar Options & Warnings

FFW: Flash Flood Warning

SVR: Severe Thunderstorm Warning

TOR: Tornado Warning – Base/No Tags

TORR: Tornado Warning – Tornado Reported

TORE: Tornado Warnings – Tornado Emergency

SQW: Snow Squall Warning

SMW: Special Marine Warning

Numbers next to each warning indicate how many are currently in effect. These numbers do not show when viewing archived data.

Current NWS warnings can be toggled off and on using the checkboxes next to each 

respective warning on the top right of the toolbar. 



GR2A also downloads & displays historical NWS warnings (2007-present) 

and LSRs (2003-present) with archived radar data. These appear and 

disappear as though it were real time.

Overlays
Warnings and Local Storm Reports

Clicking on a warning allows 

you to view the warning text 

and any follow-up statements. 

Active warning data only can 

also be accessed from the 

Windows ->Show Warnings 

Window pop-up box. 

Mousing over an LSR icon 

allows you to view more data.

1

2

1

2



• Placefiles are custom text files developed by third 

parties that are specifically designed for GR products

Can be either static files (spotter residences, law enforcement 

locations, etc.) or dynamically updated on a server (surface 

obs, SPC outlooks and watches, webcam images, etc.)

• To load either type of placefile, make sure 

the Windows -> Show Placefile Manager

option is checked. When it is checked, a 

small window should open up on the 

screen.

Overlays
Placefiles



Click the      button on the Placefile Manager window

– The following window will open

– To load a static (saved) placefile, click the      button and navigate to 

the file on the computer.

– To load a placefile located on the Internet, simply paste the address 

to the placefile in the text field (to the left of the      button)

– Click OK when done. 

Repeat the process above for each placefile

Overlays
Placefiles: Loading



Each placefile will be listed in the Placefile Manager window

– To reorder the placefiles, click the placefile in the

window and click either the      or      buttons

– To remove a placefile, select the placefile and click 

the      button

– The left checkbox next to each placefile toggles

whether the placefile is visible on the map

– The right checkbox toggles whether the placefile 

is visible above (unchecked) or below (checked) 

the radar image.

Overlays
Placefiles: Managing



Online Placefiles (non-exhaustive list and not endorsed by the NWS). Please 

note that the reliability of these third-party placefiles is not guaranteed.

http://redteamwx.com/grlevelx.html

A wide array of surface observation and outlook placefiles

https://placefilenation.com/

A wide array of surface observation, outlook, and lightning placefiles

https://cimss.ssec.wisc.edu/severe_conv/ProbSevere_V1vsV2.pdf

CIMSS ProbSevere/Tor Product (Experimental)

http://mesonet.agron.iastate.edu/request/grx/

Iowa surface obs (all networks), webcam images, NEXRAD 

Level 3 attributes

http://www.spotternetwork.org/pages/feeds/gibson-ridge

Spotter Network locations and reports

Overlays
Placefiles: Locations

http://redteamwx.com/grlevelx.html
https://placefilenation.com/
https://cimss.ssec.wisc.edu/severe_conv/ProbSevere_V1vsV2.pdf
http://mesonet.agron.iastate.edu/request/grx/
http://www.spotternetwork.org/pages/feeds/gibson-ridge


Shapefiles are static GIS files created by third parties that 

are supplemental to the overlays already provided in GR2A

– Shapefiles require both a “shape file” and a “style file”

– To load a shapefile, go to GIS -> Load ShapeFile

– The Shape File Loader box will open

Overlays
Shapefiles Pg. 1 of 2 (Advanced Users)



• In the left hand box, click the      button and navigate to the 

directory containing the shape file. Select the shape file and 

click Open

• Perform the same steps for the right hand box, but this time 

navigating to the location of the style file (many times they 

are in the same directory).

• Once both of these are loaded, click the Import button

• To remove a shapefile, go to GIS -> Unload ShapeFile and 

chose the file you wish to remove.

Overlays
Shapefiles Pg. 2 of 2 (Advanced Users)



All of the overlays in 

GR2A can be turned 

on or off by clicking 

the corresponding 

item in the GIS menu.

Overlays
GIS Data, Range Rings, and GPS Data

Table of Contents

To show range rings (25 nm 

increments), right click the 

Radar Display Window and 

click Show Range Rings.

Note: By default, range 

rings are centered on a 

radar location. Range rings 

can be centered on both 

markers and home points, 

if GR2A is set to measure 

distances from these points.

If you have a GPS device attached to your computer, you can display 

your location using the File -> GPS -> Start option. You can turn this 

display off by going to File -> GPS -> Stop. A GPS monitor pop-up will 

also open up when this is active and can be turned off using the 

Windows -> Show GPS Monitor option.



• Markers are useful for setting the storm motion and 

measuring distances between points.

• To set a marker, right-click on the Radar Display Window at 

the spot you want to place the marker. A menu will open up 

(see image to the bottom right).

• Click Place Marker Here.

• To remove the marker, right-click the 

screen and select Remove Marker.

Viewing Options
Markers

The distance between your cursor and a marker is viewable on the 

bottom status bar—second field from the left.



• GR2A will erase any marker you set after exiting the program.

• To set a marker that GR2A will remember the next time you open 

the program:

– Right-click where you want to set the marker 

and click Place Home Here.

– To remove the Home marker, right-click the 

marker and select Remove Home.

• By default, GR2A measures distances from the 

radar or, if set, a marker. You can force GR2A 

to measure from certain points.

Right-click anywhere in the Radar Display Window 

and choose from one of the three options near the 

bottom (red box).

Viewing Options
Home Markers (Advanced Users)



Go to File -> Save Image and 

select one of two options

– Entire Window: Captures the whole screen

– Radar Only: Captures only the Radar Display 

Window

GR2A can insert certain variables (site ID, 

date, product time, and product name) 

into the image filename, as well as any 

user-desired words/characters at any 

location in the filename

Viewing Options
Saving Images



• To toggle smoothing for non-velocity products, click the        

button on the Toolbar.

To configure smoothing settings, navigate to View -> Smoothing 

Settings…. In general, these settings don’t need to be changed.

• To turn dealiasing on or off for velocity products, click the       

button on the Toolbar.

To configure dealiasing settings, navigate to View -> Dealias 

Settings…. It is highly recommended to uncheck the box next to 

Convert Unresolved to ND. This will force GR2A to show velocity data 

even if it can’t dealias it correctly. This also allows TDWR velocity data 

to be displayed without having to disable dealiasing.

• To view distances in metric units, go to View -> Show Metric Units

Viewing Options
Smoothing, Dealiasing, and Units

Table of Contents



• Cross sections can be made of all Level II products.

• Click the      button on the Toolbar to activate the cross 

section tool.

• Click and drag your mouse across the area you wish to make 

a cross section of. Release the mouse button when finished.

• A separate cross-section window will open up.

Cross Section Mode
Introduction



Product to load as 

a cross section

Product date/time

Position: Moves the cross section back and forth in the 

horizontal. Is moved on a line tangential to its orientation.

Swing: Pivots the cross section on its left axis by about 30° in 

either direction.

Turns smoothing on and off. Note: will only work if 

smoothing is activated on the main program window.

First Image 

in Sequence

Last Image in 

Sequence

Previous Image
Next Image

Refresh Data

You can also use the arrow keys to 

navigate through time in a cross section

Save Image

Cross Section Mode
Window Panels



If environmental data are available, GR2A will plot the 0° C and -20° C 

levels on the cross section as yellow and red lines, respectively

Cross Section Mode
Additional Notes

The status bar at the bottom of the cross section window is an 

abbreviated version of the main program and contains (from left to right): 

program status, distance & bearing from radar/marker, product value, 

altitude, and coordinates (when plotted on background map, if visible).

Table of Contents



• Volumetric displays allow you to get a 3D look at a storm.

• Volumetric displays are only available for BR, BV, SRM, SW, 

and rotation (special GR2A calculated product).

• To create a volumetric display, click the       icon on the 

Toolbar.

• Move your mouse to where you want the center of the cross 

section to be, then click and drag outward. A box will grow 

outward with your cursor showing the area that will be 

analyzed.

• When you let go of your mouse button, the volumetric 

display will open in a new window. 

Volumetric Mode
Introduction



The volumetric display window consists of four parts

Toolbar Product 

Information 

Panel

Radar Display
Status Bar

Volumetric Mode
Window Components



• The Radar Display shows a smoothed three dimensional radar image on 

top of the 0.5° image of that product.

• Click and drag your mouse on the display to rotate the image.

• Like a cross section, the 0° C and -20° C lines are plotted if the 

environmental data is available as yellow and red lines, respectively.

Volumetric Mode
Window Components: Radar Display



Product Information Panel

The Status Bar is located at the bottom of the window and displays your 

cursor’s latitude & longitude and azimuth/range from radar.

Date and time of the volume scan start

Available products to select from

Lit Volume: View the storm using multiple 

transparent layers, which can be set by the user 

(see the color table section for more)

Isosurface: Only display data that is of a certain 

value (again, see the color table section for more)

Volumetric Mode
Window Components: Info Panels



Save Image

Sync with Main Window

Volume Display Settings
You shouldn’t have to change anything 

in here other than sky color

Volume Alpha Settings
Controls how the 3-D image 

looks, more on that on the 

following pages

Light Settings
Change the ambient light and 

light angle. Play with this until 

your heart is content

Volumetric Mode
Window Components: Toolbar

Animation Controls



• Click on the       icon on the Toolbar. The Volume Alpha window opens.

• The color scale is oriented along the bottom of the window, with a line 

stretching from the left to right side of the black window. This line 

controls the transparency of the colors.

• The closer to the top of the window the line is, the more opaque the 

color directly under the line becomes; the closer the line is to the bottom 

of the window, the more transparent the color under it becomes.

• You use a series of click and drags with your mouse in the window to edit 

the transparency of colors.

Completely Opaque

Completely Transparent

Examples on 

Next Pages

Volumetric Mode
Editing the Volume Alpha



Let’s look at a few examples and the resulting volume images

When you first open the Volume Alpha window, 

it will likely look something like this 

(unless you’ve already edited it):

And the volume image looks like this:

But we can make 

this so much better…

Volumetric Mode
Editing the Volume Alpha: Examples



Let’s get rid of the low reflectivity values

Click and drag the cursor along the bottom of

the window over the lower end of the scale to 

make the low values transparent

And the volume image now looks like this:

Somewhat better, 

but the green is still 

overpowering…

Volumetric Mode
Editing the Volume Alpha: Examples



Let’s lower the strength of the green and make it more transparent

Move the cursor a few shades of green up the 

scale, then drag a little ways off the bottom until 

you reach the yellows to make the rest of the greens

transparent

And the volume image now looks like this:

Getting there, let’s 

do the same to the 

yellows…

Volumetric Mode
Editing the Volume Alpha: Examples



Now let’s make the yellows more transparent

Move the cursor a few shades of yellow up the 

scale, then drag a little ways off the bottom until 

you reach the oranges to make the rest of the yellows

nearly transparent

And the volume image now looks like this:

That green is still a 

bit much…

Volumetric Mode
Editing the Volume Alpha: Examples



Now let’s make the greens more transparent

Drag the cursor along the spike over the green to

dampen it out a bit. Also drag the cursor over the 

rest of the greens to make them more transparent

And the volume image now looks like this:

You’re probably 

getting the drift of 

what we’re doing. 

Let’s look at some 

final products…

Volumetric Mode
Editing the Volume Alpha: Examples



Ideal Use:

Hail Detection

Volumetric Mode
Editing the Volume Alpha: Examples



Ideal Use:

Viewing All Levels

Volumetric Mode
Editing the Volume Alpha: Examples



Velocity

Note that the transparency effects are

applied to both inbound and outbound

values.

Volumetric Mode
Editing the Volume Alpha: Examples



• Once you’ve edited the transparency to your liking, you 

can save your settings by right-clicking the Volume 

Alpha window and clicking Save Alpha Table….

• You can then load your saved settings by right-clicking 

the table and selecting them from the list on the pop 

up menu.

• The settings only work for the product they were 

created for (i.e. You can’t load the saved settings for a 

reflectivity product on a velocity image).

Volumetric Mode
Editing the Volume Alpha: Saving Settings

Tip: When editing the transparency curve on the Volume Alpha window, the 

exact value your cursor is at is displayed at the very top of the window.



To change the isosurface values, simply click and drag the triangle located 

under the color table on the Volume Alpha window

Examples
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• Navigate to View -> Color Table Settings…

• Choose the product you wish to set on the left side of the screen.

• Click Change, navigate to the directory that contains the color table file 

(.pal), and choose the file.

• Repeat for each product you wish to change.

• Tip: You can also drag a color table file into the Radar Display Window 

to change the color table.

Editing Settings
Color Tables



• GR2A automatically downloads aerial imagery to use for a 

background image. You can toggle this imagery off and use a 

single color instead.

• To change this color, go to GIS -> Settings -> 

Background Color… and set the color.

• The two color items below Background

Color… are used to configure the aerial data

and shouldn’t need to be modified.

• To turn off high resolution aerial data, 

uncheck the Enable NAIP Imagery box.

• To reload the NAIP imagery, right-click the 

Radar Display Window and select 

Reload Visible Tiles.

Editing Settings
Backgrounds



To customize the how warnings look on the screen, go to 

View -> Warning Settings…

– The warning server shouldn’t need to be touched

(http://warnings.cod.edu/)

– Click the colorized line next to 

the warning label to change line 

color(s), style, and width.

– To toggle between default NWS

colors and GR2A Colors, click the 

appropriate button on the right

side of the window (red circle).

Editing Settings
Warning Colors



• Very useful for controlling zoom settings and looping speeds

• Go to View -> Animation Settings…

– Zoom Steps: The smoothness of the zooming. Higher numbers = smoother, 

but slower.

– Zoom Amount: How much the program zooms in or out with each 

click/turn of the mouse wheel. The default value of 1.25 is a good starting 

point.

– Speed: How fast the images loop

– Hold Last: How long GR2A holds 

the last image in a loop

Editing Settings
Animation Settings



All of the overlays in GR2A can be customized

– The settings for each variable are under the GIS -> 

Settings menu

– These settings include font color,

font style, and line color.

– City Thresholds defines the types

of cities shown at a particular

zoom level

– Show Always List defines what

cities are always shown 

regardless of the zoom level

Editing Settings
GIS Icons



Changing how GR2A calculates VIL and Echo Tops

– Algorithms -> Algorithm Settings…

– Max VIL DBZ: Maximum reflectivity to 

be used in calculating VIL

– Echo Tops DBZ: Lowest reflectivity 

value to be used in calculate ET

Changing MDA Threshold Settings

– Algorithms -> MDA Settings…

– Can change the ROT threshold and

count at certain ranges from the radar

(probably won’t need to change)

Editing Settings
Algorithms (Advanced Users)



• GR2A downloads 0° and -20°C heights from the RUC when polling live 

radar data in order to calculate hail sizes

– These heights can be found at Algorithms -> Environment Settings…

– Dates that data were downloaded are viewable on the left column

• Once the date is selected, the data 

for each hour is viewable in the main

window.

• To add past sounding data, go to

http://rucsoundings.noaa.gov/. 

Choose RAOBs as the data source,  

select the date, and type in the ID of

the closest RAOB site. Click the Ascii 

text (GSD format) button. Copy entire text sounding data and click Paste

in the window. GR2A will confirm that the data was added.
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Upgrading
Importing Old Settings

• For users of GR2A 1.x, GR2A 2.x allows users to 

import many settings from the older program.

• In the Menu Bar at the top of the program, click 

File -> Import… and then choose which items you 

wish to import. 

Note: GR2A 2.x will not import 

color tables from GR2A 1.x. 

Those will need to be set up 

manually.



Upgrading
Updating GR2A Version 2.x

Users of GR2A version 2.x can download the latest update for the program 

at http://www.grlevelx.com/downloads/gr2analyst_2_update.exe.

It is highly recommended that all GR2A owners join the GRLevelX Owners 

Forum to receive product support and update notifications.

Thanks for viewing this training! 

This document is intended for free use by all users of the GR2A product, including public, 

private and government entities. This training guide is not endorsed by the developer of the 

GR products or the National Weather Service.
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